HELP! Sound is OFF SYNC on ATV 4K (Infuse Pro 6)

Hey

So i have a very big issue here. I bought myself a ATV 4K yesterday to be able to use Infuse (I bought the Infuse Pro 6). All my files are on a WD My Cloud NAS. I have the NFS setup so Infuse can reach the files from my NAS. Now to my problem. Every movie I play, the sound is off. The sound comes a few milliseconds before the actual speach if that makes sense, and thats very annoying. When I try to play the same movie via KODI om my TV its a perfect sync. My TV is Philips 55PUS7272/12.

On my ATV i have the settings of matching the source ON on both things (refreshrate and the other one) still same issue.

Does anyone know what to do? My HDMI is 2.0a if that matters.

Thanks.

First, what do you have for the audio output settings in Infuse? Second, do you have a home theater receiver or just a tv? If you have a receiver, what is the connection chain for the ATV “ATV > RCVR > TV” or “ATV > RCVR > TV”?

Hi
Its very simple for me. My ATV is directly connected to my TV. I dont have any home-theatre sound system or receiver and I just use the TVs speakers via a HDMI 2.0a.

Router ← NAS
Router ← ATV
Router ← TV

ATV → HDMI → TV
Then in Infuse i fetch the videos via NFS (Even SMB gave me the same sound issues). I have also tested Infuse Pro 5, still same problem.

I have now noticed that the sound gets perfectly synced if I turn OFF the “Match Refresh Rate”-setting. Very strange. Should maybe be the other way around. My ATV is on SDR 4K 60HZ (My TV can use both 50 and 60HZ).

On my ATV i have tested all possible sound settings, and even on my tv (that barley has any sound settings) but still the same problem occures.

Where do I find sound output settings in Infuse Pro 6?

ATV is tvOS 12.4.

1 Like

Does your TV have sound sync settings? Have you updated the firmware on your TV? I know there was some sound sync issues with some LG TVs that were fixed with firmware updates.

Sorry, I meant the audio settings on the ATV. There’s a user guide that lists the preferred settings here Audio Options (tvOS) – Firecore

Often there is a setting on TVs for sync issues. Maybe we can find a solution from someone with a similar model.

EDIT TO ADD: Looked at the manual for your tv here https://www.download.p4c.philips.com/files/5/55pus7272_12/55pus7272_12_dfu_eng.pdf and on page 54 they discuss setting a “Audio Out Delay”. That may be a starting point.

Thanks but that did not help, still same issues until I turn of the match frame rate on the ATV. Regarding the audio options I have tested them all from the ATV and on my tv there is not that much options. I switched that thing on page 54 to on (was off) but still same thing.

There were multiple sections there on syncing sound to inputs with multiple settings on the tv to accomplish this. I’d recommend you read through that whole audio settings section and see if you can get it dialed in.

So, I have tested ALL sound settings on my TV and the problem still there. Sound sync is perfect ONLY with match frame rate OFF.

Interestingly I’ve had sound sync issues on my new Apple TV 4K and new Samsung QLED with a Sony Soundbase. Never thought of checking the TV sound sync settings. They were set to 100 (by default) for some odd reason. Changed the TV sound sync to 0 and it’s fixed my issue. :+1:t2:

1 Like

I’m from the vacuum tube era of electronics and it took me a long while to dig through the tomb of just audio settings on my 4K LG. Glad it gave you a hint as to the direction.

Now if I could just master the darn CEC between the TV and receiver I’d be a happy camper! LOL

I had a similar issue until I realised that all I needed to do was connect my Appletv to my TV on HDMI port 1 and then another HDMI cable from the eARC HDMI port on my TV to my Soundbase. Now my TV remote controls the Appletv navigation and the volume on the Soundbase. When I power the TV it powers the Atv and the Soundbase. Same for powering off the TV.

I think my set up is possessed, it will work for about a week and then it starts getting slower and slower between me turning on the TV and CEC having the receiver power up. Then it just doesn’t and I have to power up the receiver using it’s remote and then every thing works again for about a week. Got another new set of HDMI cables to see if one of them may be a weakling and causing issues.

Next step is to sacrifice a chicken on the receiver and see if any spirits depart.

Uh. I would’ve said new cables but if you’ve done that then I’m all out sorry. :man_shrugging:t2:

Mine works well for a few week then for some reason starts having a bad time an I have to unplug the Atv HDMI cable and plug it in again and all is good. It’s kinda stopped bothering me now :rofl: My next step is new cables as I think the one I have probably isn’t best for 4K.

1 Like

Maybe one day the EE community will get together and come up with a set standard for CEC and not just a “suggested” format so all manufacturers will comply with the standards instead of each adding their own “secret sauce” to the CEC recipe.

Oh well, at least I’m not sitting across the room from a 13" Zenith B&W and having to get up and go change channels to a different one of three.