help pls "This device isn't eligible for the requested build"

I have my ATV on 4.3 Jb and want to upgrade.

I can’t upgrade via normal way on the ATV and i want to upgrade and Jb my ATV with the new software. When i use seasonpass everything go’s normal. but when iTunes want to restore i get the message.

 

“This device isn’t eligible for the requested build”

 

Help what is wrong. i’m already searching for 2 days what the problem is. When i push the restore button in iTunes i get the same error. :-((

i have the latest seasonpass 0.8.1, iTunes 10.5.2, running on lion osx,

Grtzz

Jupil

I would try deleting the following items (maybe you have something old) :

 

/Users/{YOU}/Library/Application Support/Seas0nPass/Firmware/*.ipsw

/Users/{YOU}/Library/Application Support/Seas0nPass/*.bundle

/Users/{YOU}/Library/iTunes/Apple TV Software Updates/*.ipsw

 

Then run Seas0nPass again to recreate the required files.

Good luck. 

Did you use tiny umbrella for backup?

I did, the solution is to set in the advanced settings to let your hostfile not to look for cydia servers but the original appleservers instead.

Rgds
Ton

 

Is what i did today and yessss it worked… :wink: thx now trying to save my blobs with tinyubrella.

 

thx :wink:

This worked for me!

 

http://www.cutviews.com/how-to-fix-this-device-isnt-eligible-issue-in-itunes/10305

Jailbreak to 4.4 doesn’t work with error “isn’t eligible for requested build” or code 1604 when tiny umbrella working. After uncheck the advanced option in tinyumbrella “Set Hosts to Cydia on Exit” every thing work well.

I tried Trousers suggestion and still itunes will not restore. I have rebooted the my MBP, trashed and reinstalled seas0npass, I can’t find what’s holding itunes back. 

Any help would be appreciated.

 

Thanks,

CG

Update, tried again this morning. I found James “itunes restore errors” post and downloaded tinyumbrella and tweaked pref as suggested and all seemed to go well but when connected to TV nothing showed but a blank screen. Retried restore and got error 14, then got error 1600. I started over, trashed tinyumbrella, reset atv2 to apple firmware, trashed seas0npass and associated files. Downloaded and ran Seas0npass. It finally worked, JB ATV2!!!

Problem appears to have had something to do with the hosts file, but I don’t know what.

 

Thanks for the JB and all the troubleshooting posts.

 

What i exactly did was, trash everything. Then i did a restore first of iTunes (original software) and then i repatched my ATV with season pass. 

everything worked perfect. ;-))

 

grtzz