*Help Needed* Apple TV 2 iOS 4.3 Jailbreak

Alright well here we go. I just purchased an Apple TV 2 last night. The iOS version, as stated in the About section, is 4.3 (8F455). Now here is where it gets interesting. I could not restore the stock firmware because it appears that Apple has stopped signing it (correct me if I am wrong here). So what I did was put the device in DFU mode and used USBVIEWER to find my ECID. I created a custom device and was able to save my SHSH Blobs to Cydia using Tiny Umbrella. The SHSH Blobs saved were 4.3.0 and 4.4.2. Ok so in theory I should be able to set the hosts file and restore the 4.3 firmware, in theory.

So the next thing I tried to do was use Seas0nPass to flash the custom IPSW file. (I was getting the Device not authorized until I figured a way of saving the SHSH blobs). In conjunction with TinyUmbrella and iTunes when I attempt to restore the Seas0nPass IPSW it sits at Preparing to Restore Apple TV and just sits… and sits… and sits some more until it times out and throws an error, usually -21. People claim it is a bad USB cable. The cable is from my Blackberry Torch and has been used in a total of 3 different outlets and rarely leaves its outlet in my kitchen.

Next I tried greenpois0n (rc6 and rc6.1). I put the device into DFU mode… click Jailbreak… waited 2+minutes after the jailbreak was “complete” but to no avail. No jailbreak, no greenpois0n. I have tried multiple methods to jailbreak the device using greenpois0n. With the Power Plugged in after being in DFU, no power at all just USB, Power connected after the jailbreak was completed before unplugging the USB. All to no avail.

My last ditch effort was going to be Sn0wBreeze but it as well uses iTunes for the restore.

The PC is a Windows 7 32Bit Netbook (Works fine for all my JB needs with my iPad). Something to note that when using iTunes to restore while in DFU mode Windows pops up and says the device will respond faster on a Hi-Speed Port. Oddly enough they are all Hi-Speed ports without any other devices connected.

I am at a complete loss at what to do and hopefully someone here may have some ideas. I do have an alternate PC that I am going to try tonight my only question is will I need to capture the SHSH blobs again from the device when using TinyUmbrella and iTunes to restore (I don’t think I would as it would go to the Cydia server to get them).

Thanks,
Matty

So I hate to bump a thread but I am really at a loss. I tried a different computer with a different USB cable and still nothing. I am able to restore the stock 4.3 iOS but not the custom IPSW.

Apparently Apple is still signing 4.3 because I just sucessfully restored my new ATV2 on 4.3 using Seas0nsPass.  I’d give your custom firmware another try without TinyUmbrella TSS server.  

You might also want to try un-installing your iTunes and install a fresh version before restoring.  I know following the instructions in this post have helped me in the past. http://forums.macrumors.com/showthread.php?t=920629&highlight=

Without TSS I get 3194 but because they are still signing it I was able to backup my SHSH blobs. I have tried on 2 computers and am noticing that once iTunes says preparing to restore Apple TV the device drops off and back on and says you can perform better on a hi-speed usb 2.0 port which it is plugged in to. This happens on both computers. I am reformatting the one to Windows XP to try it on. I will report back.

Well it finally worked after 4 days of trying to restore and not doing anything any different… I guess it is just a tedious process.