Help! My ATV is Bricked

After installing ATV Flash my ATV was running, albeit very sluggishly in terms of remote commands. Now after a few days the thing is a brick. Its boots up to the main screen but will not do anything after that. Ive tried several remotes and my iphone remote, both get no response from the ATV, its just frozen. My iphone remote does not show any movies listed on it as it normally would but my itunes still sees it once it boots up. Since the remote wont control it, how do I reset it to factory settings to start from scratch?

The Baron

What version of Apple TV software are you running on your Apple TV? You must have the current 2.1 version installed prior to installing the aTV Flash.

To restore your Apple TV hold down the minus and menu buttons for 6 seconds when the Apple TV is on, or as it starts up. This will take you to the Recovery screen where you can choose to Factory Restore the Apple TV.

I have the same issue. The Apple TV has the most up to date software and aTV.

It boots up and then doesn’t go beyond the menu screen (as if the remote is not recognised). After a while it goes to screen saver, so I guess it’s not frozen, just not responding to remote. The light on the front does change when pressing the remote buttons but nothing happens. I have tried the reboot via remote but nothing happens there either.

I was able to connect via iPhone and FTP if that helps, I just can’t use a remote.

I do notice that when I boot up, it seems to go through the process twice.

I do have ssh access if that helps? Any ideas on how I could do a restore via terminal?

Any help/suggestions would be appreciated.


Page 40/41 of the apple tv user guide. if you don’t have it available here it is scanned online

No joy. The remote works on my laptop and although recognized by the apple tv doesn’t actually function.

Does anyone know if you can put apple tv into restore mode via terminal / ssh ?

Cheers David

For reference, if you can ssh you can do a restore using the following command in terminal

sudo /usr/sbin/recovery_reboot

Some users have reported issues with paired remotes after installing the aTV Flash.

You can easily unpair your remove by holding down the menu and rewind buttons for 6 seconds.

Once you have the remote working again, you can re-pair the remote with the Apple TV and it will continue to work.

If you want to restore your Apple TV you can hold down the minus and menu buttons for 6 seconds while the Apple TV is on, or while it starts up.

I have the same problem - I get the amber light whenever I try to use the remote, so there is no way to access any of the menu items. Happened minutes after flashing the unit, and since I can’t access the menu’s, I can’t do a factory reset. And since the remote does not function at all, I can’t use the Home + >> trick - all I get is the amber light. Tried the Apple Remote on my iPhone, but that doesn’t allow access to the aTV’s Settings menu, so no possibility to remotely reset the unit. It seems that without a functioning Apple remote, I’m trapped in a rather nasty vicious circle.

I will try the SSH terminal line command a little later, but as I’ve seen a few of these cases being reported, I was wondering if Apple Core LLC has readied a neater solution?

Even though the AppleTV is showing you an amber light, the unpair command (Rewind & Menu) will still work. I lost my Apple Remote once and had to use my MacBook remote and I was able to perform that command and unpair my lost remote with a second remote. It should work out for you, if not then I am not sure if there is a preference file that can be deleted and have the AppleTV reboot to remove the pairing. I’m not at home right now, but I’ll look into it later tonight.

Thanks madcran, I wish it were that simple :frowning: I’ve repeatedly tried the menu + rewind trick with both my aTV and iMac remotes, but no joy. The box is refusing to accept any input from the remotes - always the amber light.

Deleting a preference file sounds interesting though, in case you have any further thoughts on that line of attack.

No freaking way!!! I found it! After much searching and using my MacBook as a test subject, I found the file that tells the AppleTV or MacBook if it is paired or not. Use Fugu (Mac) or WinSCP or Putty (Windows) to ssh into the AppleTV. Go the the root “/” of the drive. Go into the Library folder and then into the Preferences folder. Inside there you should see a file called Delete that file and reboot your AppleTV and now you should be able to use any remote. It worked on my AppleTV so if it does not on yours, then I’m not sure what is wrong with it.

I have this prob now… since i reinstalled it and then updated it and then used the patchstick it now loads with the apple tv and then u see the apple and then it reboots itself and again and again.

what can i do?

You must have AppleTV 2.2 with aTV Flash 3.3.1. You need to either edit your Restore image on your AppleTV to 2.1, restore the AppleTV, and install aTV Flash OR you can download aTV Flash 3.3.2 and patch the AppleTV with that. Apple changed some things in 2.2 and some components of the patch don’t work yet.

Be aware that 3.3.2 is not fully functional yet, Sapphire, and ATVFiles are not working until those developers get the new versions out. On the other side of this, changing the Restore image is risky, but some users have been able to do it. You should have unix knowledge and we can not endorse this, but you can at least download the pdf and read about it.

Hopefully that is the problem you are having. If not let me know.

my patchstick was the lastest atvflash on it

i tried the pdf but cant ssh to the appletv as its not showing a ip address

You have two options to try.

First, you can try using this command instead of using an IP address:

ssh -1 frontrow@AppleTV

That is the default name for an AppleTV unless you changed the name in iTunes when you set it up. Password is frontrow.

Secondly, you can use a program like Fugu or Transmit, it should show you the Bonjour name of the AppleTV which by default is AppleTV.local Try using a program like that. There is also a possibility you can use Fugu to see the IP address of the AppleTV. If you click on the Bonjour logo: (shown below in picture)

and the drop down menu should show you a couple IP addresses. Just try these settings below until you can get in so you know what the IP address is:

tried this and its not working… im pretty sure that its on the network via the cable but is not on live!

as when it starts it just shows a apple and then flashes every 1 minute or so.

i am in but using a boot loader… and have unbunt

any ideas?

I’m having the same problem. After rm’ing the IRRemote prefs file, it no longer showed my remote as unpaired (amber flashes). But now, I just clicks from AppleTV when I use the remote - no menu changes, no status light flashes.