HELP! Is my ATV bricked? Won't even restore in Itunes

Hi all

 

My ATV2 has been jailbroken successfully on 5.3 since the latest seas0npass version came out early Jan.

I’m no stranger to the jailbreak process and have now done 3 x ATVs on 5.3 without too many issues.

Last night my own ATV on 5.3 crashed and then wouldn’t get past the Apple logo screen after reboot. No bother I thought, Apple are probably still signing 5.3 so I’ll just redo the jailbreak process. Sadly with my main Win7 PC, with seas0npass I 'll  get stuck on the ‘Extracting software’ part and eventually seas0npass will give up and give me the ‘Firmware restore failed’ error message. I then tried my older XP laptop and the same thing happens. Tried a couple of other micro USB cables (on of which belonging to HTC phone and had whenever even been used) and no joy, same error occurs again and again.

 

So I thought I’ll try restoring in Itunes 11, and once the unit is at least up and running with stock firmware, I’ll then later try re-jailbreaking again. What happened next is what is really worrying me. The ATV2 won’t even restore in iTunes! the beginning part seems ok, download of the firmware, extraction of the firmware, verifying with apple, than preparing apple TV for restore and this is where the process hangs for several minutes, after which I’ll get error 1601 / 1604. I have repated the whole process several times with / without power cable connected in addition to the micro USB, but this seems to make no difference at all. I have tried several USB cables, all original Blackberry / HTC / Samsung phone cables that carry data as well as power. I even had a friend come over with his MacBook and same problem, cannot restore in iTunes. A summary is given below:

 

-Win 7 PC
-Win 7 Laptop
-Win XP Laptop
-Macbook Pro
-Several original micro USB cables belonging to smart phones such as blackberry, HTC, Samsung
-Tried connecting the power cable to the ATV during iTunes restore / seas0npass jailbreak process
-Tried using seas0npass to restore to previous 5.2.1 signed version (using previously saved shsh blobs)#
-Tried downgrading iTunes 11.1 to 10.7

 

NOTHING is working, I can’t even get the stock firmware back onto the unit let alone jailbreaking.
this is annoying because a lot of google results seem to be about Win7 not detecting the ATV2, or not being able to get it into DFU mode. However I don’t have this problem, the restore process with iTunes / seas0npass gets well into way, probably 80% complete before I get an issue. It seems as though iTunes and seas0npass detect the apple TV ok and first few steps go ok, but seems to be failing at one of the very final hurdles.

 

I know these types of problems are hard for people on the forums to help with so I have already tried my best to rule out any issue myself by trying several machines / usb cables / connecting / disconnecting power cable. I have also used iFaith 1.5.9 to detect the device and it does so just fine, and even tells me which blobs I have previously saved on the Cydia server for the device. But I really am stuck and have spent several hours today and feel like I’m at the end of my tether.

Could there possibly be an issue on Apple’s server which verifies the iTunes restore process today, which may be gone next week? If yes, why isn’t restore with seas0npass not working? Or perhaps seas0npass also verifies the restore / jailbreak with Apple?

 

Any help at all would be gratefully appreciated.

My only suggestion would be to replicate everything using 2 different ATV2s.  If everything works ok with one but not the other then chances are you have a hardware issue.

Anyone?

If there are any experts out there I’m happy to upload / paste the update logs that iTunes creates whenever I try the process.

 

 

Thanks for the reply. I had thought of this but then the possibility of ending up with two bricked ATVs is giving me the creeps. If I try the restore and it fails, would the whole restore process be ignored and would the ATV still be jailbroken and bootable?

In my experience, once a restore or jailbreak fails you are left with a non-functioning unit. 

Regarding your concern of bricking 2 devices, it’s actually not that easy to brick an ATV.  Even when people here claim to have bricked their devices their usually just temporarily stuck in DFU mode.  Unless you’ve intentionally used blobs from a different device to perform the jailbreak on this device (which risks cycling the software, a.k.a. continuous loop, a.k.a. bricked) then chances are you have either overlooked something with your computers, cables, etc. or the device has an internal hardware issue. 

Right so I could borrow another ATV2 that I have access to and try to restore that. If restore works then that rules out an issue with my equipment at home, and would indicate a hardware issue with my ‘bricked’ unit. If restore fails then the borrowed unit would not be functioning, but on the plus side it would indicate too much of a coincidence, in that two units failing restore likely mean an issue with my equipment (although I’d be surprised considering the amount of variation in equipment that I’ve tried).

 

Regarding using blobs belonging to another ATV2 well I can certainly say that’s not possible. I’ve only ever jailbroekn two ATV2 in the past, the first being my current ‘bricked’ one, and the second being one thatI didn’t even need blobs for.

 

Has anyone tried a resore to 5.3 in the last few days? Maybe I’ll post a separate thread for this question.

No need for a new thread, read this: http://forum.firecore.com/topic/11033