help atv2 jailbreak errors and says 1080

Im trying to jailbreak my appletv 2 (on mac) and getting error message 1604 in itunes over and over. This has occurred after trying to install firmware thru itunes (with pressing option/restore).  I cant get into normal dfu mode to allow Seas0npass to install automatically.  I bought and changed the usb chord and still not working.  Ive tried many times to get it in proper dfu to the point where seas0npass will take over but it doesnt seem to get there. 

Im wondering if i can downgrade and then jailbreak.  Strangely, my atv2 is showing 1080p however im told that if it says that then i actually have atv3 (and cant jailbreak).  I dont think this is an atv3 however because this unit has previously been jailbroken.  It just wont work with the latest jailbreak after I updated several months ago.

Not really sure what to do and any help or suggestions are greatly appreciated as this is driving me crazy!

Sorry to tell you, but you have a 3rd gen. Apple TV.

If you see in the settings that this ATV is 1080 capable, it is NOT a 2nd generation Apple TV.  A 2nd gen Apple TV is 720 only.

Under "ABOUT" in settings, if you show a "MODEL" that begins with "MC" and has 1080 under "TV RESOLUTION,"  you have a rare and very special Apple TV.

However, I'm sure that the model number showing on your Apple TV begins with "MD," -- true for all 3rd generation Apple TV's.

Check the back bottom part of the unit if its a1378 or a14xx - this will confirm if you have a 2nd gen or a 3rd gen. 

Thanks for your replys.  I will check the bottom when i get home from work.  However, i am wondering: if mine is in fact an atv3 then there would be no way to have previously jailbroken the unit ...correct?  Thats why im wondering how i was able to jailbreak it before this...and if i could do it then why cant i now? 

I just checked and it's actually 1378 and its 720.  So it's jail breakable but im still having problems. 

try to restore the atv thru itunes, just to have a "fresh atv". Then reun seas0npass make sure youre using the latest version i.e. 0.9.5