HELP...ATV2 cant enter dfu mode HELP

Please help… i was playing around with my atv2 5.1 ,trying to downgrade to 4.4.4,when i was restoring in itunes i kept getting error 1604 message i tried 3-4 times,now itunes will not recoginise the atv2,i have tried every way to get it into dfu mode with no joy…i did try tinyumbrella but atv2 wont show up…

i think ive bricked it …please help

I found the only way I was able to get into DFU was to have the power cable connected with the USB while I was on 5.X.

yeah i did try but nothing…bet its bricked…

You can restore to the stock 5.1 in iTunes and that should revive your Apple TV.

yeah that was what i was hoping,but itunes wont recoginise my atv2.

Leave it unplugged for about 5 minutes and then plug it back in.

What does the LED do on the front of the Apple TV when you plug it in?

have left it over night.if pluged in via usb light flashes if power pluged in as well light flashes very quickly…if connect to tv via usb and hdmi light flashes but nothing on the screen other than ‘no signal’

im running out of ideas

just a quick thanjs for your input…finally got it sorted opened devices on windows found atv2 and updated driver,opened itunes and my atv2 was there…#