HELP: ATV 4K & Infuse - UpNP/DLNA Share from Synology NAS - I get No Libraries or Home Screen Sort by Genre or Cover Art Display

My Apple TV 4K & Infuse do not display the Top of Folder “desktop” Genre and Cover Art.

If I select a “text” named movie it does display the full Metadata and Cover Art once I select that movie with the MENU BUTTON.

How do I get/force Infuse to display the Infuse TOP OF FOLDER Genre and Cover Art like COMEDY, DRAMA, etc.?

Thanks in advance!

I’m not at home right now, but I remember you just long press on the icon and hit “select artwork”. There a thread with a bunch of artwork people made here in this dropbox: [Showcase] Favorite icon artwork

I’m assuming you’re referring to the FAVORITE folder when you say “top of folder.” Favorites are where you press on a NAS share and make it a star folder.

I have a UpnP/DLNA Share from a Synology NAS.

I cannot get any of my Shared Favorite Folders to appear in my Library as described below.

My Library shows 0 items and my “Desktop” or Main Screeen only shows the Shared Folders, from which I can click down to watch my Movie/TV Files.

But, I get no Main Screen Genres or Movie/TV Artwork.

Setting Up Your Library

Library is a way to group videos from multiple shares together by type, and browse using a set of Smart Filters.

Setting up your Library

Step 1. After setting up a share and adding one or more folder as Favorites, you can select which folders to include in the Library.

By default, will include all the folders you have selected, but you can manage these if needed through Settings > Library. Place a checkmark next to any favorites want Library to index.

Per James:
"Unfortunately Library won’t be available when using most DLNA/UPnP devices.

However, most NAS drives allow you to connect in multiple ways, so if you are able to remove your current share and connect via SMB, NFS, FTP/SFTP, or WebDAV everything should start working as expected."

I tried to delete my UpNP/DLNA Share a create both a SMB and NFS Share without success.

Is there an FAQ or Article that lays out the Step-by-Step for successfully creating an SMB or NFS Share, particularly one that works with a Synology NAS?

Thanks in advance.

First thing to do is make sure your NAS is set up for SMB and/or NFS and that’s probably in your Synology manual.

After that, Infuse should see it and display it in the list of available sources.

The answer is literally a quick google search away

I have enabled both SMB and NFS as SHare Protocols on my Synology NAS.

However, I cannot seem to get a successful Share established in Infuse.

Which is the preferable protocol for Infuse: SMB or NFS?

Are there any FAQ’s or Article on the Infuse Site for Setting up SMB or NFS Shares?

I don’t have a synology, I have a QNAP which is a competitor. I know on my qnap, you have to make sure you enable permissions for each user account for each share. Try creating a new user account with read only permissions to the share with your movies on it. Then restart your NAS.

Then on infuse, you just go into the settings menu and click on shares. Find your Synology NAS and type in the account credentials and look for the share folder. Then long press on the apple trackpad to save it as a favorite. Once it’s saved as a favorite, it’ll show up on the Infuse home screen.

If the Synology doesn’t show up on the shares folder, try manually typing in the IP address of the NAS.

Which is the preferable Local Network Protocol for ATV 4K & Infuse and a Synology NAS; SMB or NFS?

Doesn’t matter, either should work. FTP will also work too.

I have SMB Share fully set up in Synology.

I know this because Infuse already lists the SMB Share visible as an Available Share, and seperatly I sucessfully use the SMB Share on a stand alone Media Player, the Mede8er.

Nonetheless, I have tried and failed to setup the SMB Share in Infuse as an Active Share.

Any help on what must go in each field to create a sucessful SMB Share from Synology to ATV 4K & Infuse?

I can help in a couple hours when I get home, unless someone else chimes in first.

Thanks very much gggplaya for making your expertise available.

I am on the West Coast Pacific Standard Time.

Currently I am working from home, so anytime is good for me.

So, I Uninstallled the Infuse Pro 6.X App and downloaded a fresh copy from the App Store, and now the SMB Share magically works and all is well.

Thanks for listening and your helpful suggestions.

I was just about to check my apple tv. I’m guessing Infuse must have had a bad password or something saved and it needed cleared out.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.