Help!!!also permissions problem error!!!

when I followed instructions to install the patchstick version 3.1,after typing in my admin password, I get the message such as"Cannot change permissions". what should I do

Please help me

thanks!

applecorellc,Please help me

Hello, sorry for the trouble.

Double check that:

  1. Logged in as an admin user
  2. Have a password assigned for your account (cannot be blank)
  3. Entering the correct password.

thank you for your reply.

my system is os 10.5,and I have used the root user to try to create a patchstick but unforunately I got failed.

I got message like this

Unable to change file ownership.Please ensure you have typed the correct password.

But i am sure i have inputed the correct password (root user)

could you give me some idea?

What brand of flash drive are you using? Some drives have write protection that prevent them from being created properly.

Ihave the exact same problem. I even have the Flash drive that was suggested, I went and bought it. It tells me that the password is incorrect, but it is, I’m administrartor and I have OX 10.5.4. What do I do? PLEASE HELP

I too have this problem. Whenever I try to run ATVFlash.app from the image I get the permissions error and doesn’t allow me to continue. The password is correct, the user is an admin. Changing the password and creating a new admin user didn’t work. I have also tried using 3 different flash drives from 3 different manufacturers with the same result on each of them. I’m running Leopard with all the latest security updates installed. Java 1.4.2, 5 and 6 are installed.

Let me know if there’s anything else I can do to help diagnose the problem.

Edit: Ok so I tried using a mounted writeable dmg file and that resulted in the same problem so I’m pretty sure it’s not a hardware problem.

Make sure you have a password assigned for the account. The password cannot be ‘blank’.

Blank password is not the issue in my case, but I still got the permission error.

Seriously, can you read? I have a password, I changed the password. I created a new account with a password. Then you tell me the pasword cannot be blank. Is it just a bot that answers questions here?

Your flashy GUI installer obviously has a problem with some (all?) instances of a fully updated copy of Leopard. How do I know this? Well I had another hard drive with a copy of Tiger on it. I swapped it into my MacBook and the installer worked flawlessly.

Perhaps you might want to give people access to a disk image as a fallback.

Sorry about the trouble, we will have to look into that. Are you using File Vault, or any other security software by chance?

No file vault is not enabled, nor is any other piece of security software.

I do have Boot Camp and Parallels installed though in case that’s relevant, but Parallels wasn’t running when the key was being made.

No need to apologise for the trouble. I understand problems occur with software, and I’d have had no problem waiting for a fix. I just didn’t appreciate the stock answer that showed that my post wasn’t even read.

Anyways, best of luck sorting it out, I’d be happy to pass on any other information that my help.

I too am having this issue. I purchased the flash product yesterday after upgrading my firmware and now I’m stuck! The first attempt to create a patchstick worked ok, but the patchstick didn’t work on my apple tv. So It tried to create a new patchstick with a different USB drive and got the dreaded “cannot change ownership” error message. I then tried several other usb drives, all of which had the same error. I then tried to create a patchstick on a completely different mac (g4 notebook running leopard) and got the same problem. I even tried the original flash drive that worked the first time and it gets the error message as well. Today I will attempt to create a patchstick at my office, not sure if the network has anything to do with the problem, but I tried a lot of other configurations unsuccessfully.

This is unacceptable for a $50 piece of software. if this doesn’t work by end of day today, I want my money back. Any idea how I go about doing this?

We are looking into this issue to find the root of the problem, and should have a solution shortly.

One user has reported overcoming the problem by restarting the computer, and running the installer again. This may suffice as a workaround until the root problem is found.

Sorry for the trouble.

Maybe some info to solve the issue;

This week I downloaded the software and tried to create a patchstick.
I received no permission error and seemed to have created the patchstick succesfully.

I tried installing it, but it did not work (the patchstick was created very quickly, which I found strange as it should take about at least 5 min)

I tried to create the patchstick again on the same mac (macbook pro) this time I received the permission error.
Whatever I tried, each time I got stuck with this permission error.

Luckily I have also a mac mini, so I tried the whole procedure again with the same usb stick for the first time on this machine.
This time all went fine. No permission error, creating of the stivk took arround 7 min and I successfully patched my atv.

Hope this info helps solving this issue.

Just an update. We’ve determined the cause that some users are experiencing this issue.

We’re working on an updated package that should correct any problems, and plan to have a beta release within the next 1-2 days.

If you are interested in obtaining a copy of the beta package, please send an email with your full name and email address.

http://www.applecorellc.com/contact.php

Thanks

I tried the new 3.2.2, but now after the Options screen it doesn’t ask for a password at all and gets stuck at 0 %.

Tekytek

What brand/size is your flash drive?

I have used the flash drive previously and it worked with earlier versions. It’s a Pretec 1 gig.

I just want to confirm that this happened to me too using a stick that I was able to use successfully on my mac with a different hard drive.