HELP! 3.2.2 Upgrade not working as planned!

Have just upgraded to aTV 3.2.2
However, I seem to be missing a couple of items on the menu - namely, Media and DVD.
All I get is Internet, Jaman, Files and Maintenance.
And I can’t seem to ftp to my appletv using cyberduck or ssh thru terminal.
Have tried with 2 different flash drives, each of which has worked in the past.
Have also done a full factory restore, upgraded to latest appletv firmware and then tried the patchstick.

Can somebody pls help me? I’m totally lost without access to my SMB shares!


kenadianz :o

and here i was, about to send applecorellc an email asking where my v3.2.2 download links was in my account pages, but i think i’ll hold off! am i just blind tonight? or is your problem widespread & they pulled it down until they fix it? hope you’ve still got 3.2 to go back to…

Make sure you are running the latest 2.1 Apple TV software. The current plugins are not compatible with older versions.

You can check your version in the Settings > General > About menu.

I’m running the latest AppleTV software v 2.1

Any other ideas?