HDR shadow detail on Sony A9F

running some HDR10 test patterns it seems that Infuse cuts all details below 84. I remember
this was an issue in earlier versions but was fixed at some point.
Maybe it has been re-introduced with TV OS 15?
I’m using Infuse Pro 7.2.1 (3874) on an ATV 4K (old model)

Can you check to ensure both of the Match Content options are enabled on the Apple TV?

Both options are enabled. If I play the test pattern with the player of my TV I can see the bars 66-80 are flashing, so its definitely not the TV setting.

TV settings can also vary by input and signal type, so it might be worth playing with the settings a bit to see if that makes any difference.

If you want to upload the actual sample you’re playing we can review it here.

I uploaded the video. It’s the 03. black-level-v3.mp4 from the AVS test pattern collection.

Try adjusting the gamma level on your tv.

My TV is calibrated, it’s definitely not the TV or a setting. If I play the same file with the shield
or the internal Android player everything is fine.Even turning up blacklevel to max on the TV won’t make the bars flash.

Just tried your sample here on my ATV4K and all the bars down to 66 were flashing. :thinking:

These are the settings I’m using on the Apple TV.

Even with your settings (my ATV is usually set to 4k SDR RGB high) all bars below 84 won’t flash :frowning:
I’m 100% sure that is was working as expected before, but last time I checked was before the TVOS 15 update I think

Maybe try using the ‘Reset Video Settings’ option and setting them up again?

If you’re using a different HDMI input for the Shield, I’d try connecting the ATV to that input to see if it performs differently.

I tried this already, unplugged the ATV and plugged the Shield using the same input and cable.
Result is the same, bars flash on the Shield, but not on ATV via Infuse…


Am interested to test my TV for this as well. Any idea where can I get the test pattern?

What kind of display do you have? It is possible that it is due to dynamic tone mapping, because Infuse sends out fixed HDR metadata values for all files (in this case 4000/1000 instead of 1000/400).

This is even more evident in these test files: [AVS white&color clipping test files]

I have a Sony OLED (KD-55 A9F). The Sony ignores all HDR metadata anyway and analyzes
the video signal on the fly to adapt the tonemapping dynamically.

1 Like

Just found the original post which describes exactly what I see on my TV:

That thread is pretty old, and the changes were implemented long ago.

Tried on a few more setups and things still seem to be fine.

On my LG OLED I did have to adjust the ‘Black Level’ setting from ‘Low’ to ‘High’ to avoid black crush and get the correct near-blacks. Not sure if your Sony OLED has a similar setting.

I know it’s an old thread and I also know that it used to work on my setup. But now it doesn’t and no matter what setting I change it won’t work. It works as expected with a Shield, with the inbuilt TV android player and even with a 20 Euro cheap Android box
running CoreElec with Kodi. Maybe someone else with a Sony OLED TV could verify this?

This post is from an A9G owner, but the settings might be the same on your A9F.