HBO GO Stopped Working

A couple days ago HBO GO stopped working. I can log in, select what i want to watch, it starts the HBO screen with the rating information then when it should be starting the video it goes to a screen that says “checking for more videos”. I’ve changed my host file, I did a fresh jailbreak of 5.3 and did the version spoof to see if any of those would help, and nothing has. Is anybody else having this issue? I’ve done a bunch of searching and can’t find anything.

I have had the same problem starting on 7-5-2015. Nothing has worked for me either, I also get the “checking for more videos” prompt as well. However HBO GO does work on the iphone & ipad (non-jailbroken) and I can airplay it to my atv2 but thats not why I have my atv2! If anyone has had the same issues please post and hopefully we can find the source of the problem.

The same is true for me: AppleTV 2, running ATV Black 2.5 with Maintenance Version 2.5-25 installed. I don’t know exactly when HBOGo stopped working, but it’s only been a few days ago, not exactly sure. I have tried going into the HBOGo app and de-authorizing and re-authorizing the AppleTV, all without an error, but when I view any HBO program through the HBOGo app, I get the HBO logo, the rating tile (e.g., PG, R, etc) and then “checking for more videos.” I’ll open a ticket with support and see what’s up.

Same here. Ever since the aTVFlashBLK Maintenance update. I also can’t log into Hulu any more. Says, “Hulu Unavailable…”

I opened a ticket on this with HBO last week - they did jack shit. As in, automated response with a weblink to the support page. I emailed back saying, no, can you just tell me if you guys altered the way the videos play/whatever, same f-ing response, probably from a robot. So pissed, I could stab the non-existent techy who sends me the same bs email everytime.

And no, I didn’t update ANYTHING - I’ve never been able to get the update stuff under the maintenance menu to work. My theory is its on HBOGo’s end since everything else seems to work fine (xbmc, netflix, don’t know about hulu). Still running untethered 5.3.

Speaking of support tickets, I filed one with FireCore several days ago, and I haven’t received a response.

Same thing here! ATV2 running Infuse 2.5. Help us get HBOGo back! Thanks

I am also having this issue. Has there been any update or solution?

Same here. Lately my experiance with ATV is one failure after another…

Seems the level of support for FireCore has tapered off since the legalization of marijuana in the state of Colorado . . .

Nothing to do with firecore. I didn’t update anything just stopped working probably with a new storeFront (Apple TV apps file). Unspoffed my aTV thinking it was the culprit but still the same issue. gonna try to play around with the Info.plist but I’m not sure if it will help…will keep you posted.

Looking forward to whatever info you can provide to get this issue corrected.

same issue. “looking for more videos …” is the error, then it pops back to the HBO Go screen.
Mine is an ApTV 2 just plain jb’n. The only other thing I can think of, I just updated to Kodi 14.2, though I can’t see what that would effect HBO Go.

I held down Play/pause and ApTV 2 updated to 7, but everything still works as it did or didn’t.
Unfortunately, nothing better about HBO.

Same exact issue since the 5th of July. Nothing changed, just stopped working. I think this is server-side.

Since it works on the aTV3 perfectly it would not be the HBO servers whatsoever. The client is the issue FOR SURE. I would assume it even works on non-jailbroken aTV on iOS 5.3. More then likely apple has built in a jailbreak detection into this added site (app) on the storeFront (aTV home screen) or other config file that is breaking this from working. Until if/when this is resolved you can do a few things:

A. Un-jailbreak your apple tv (I’m guessing you don’t want to do this and neither do I)
B. Run HBO GO/MAX GO/Showtime anytime (or others) using the browser app
C. Install PlexConnect and attempt to install the HBO GO/Max GO channels (not sure if this trick works anymore) google to find out.

Good info! Thanks for the tips!

When I said server side, I meant they made changes at the servers. This makes sense with what you said and what I meant. I was just saying that nothing had changed on my end and so they must have done something to only accept newer client versions or maybe they can see this is a JB aTV.

Either way it just plain sucks.

As I already posted on July 11 - its SERVER SIDE.