Having Zero Luck Jailbreaking Apple TV 8f455

I picked up an Apple TV this week and was planning on jail breaking it right away


I’ve tried everything I can think of, but I can’t seem to jailbreak it.


Downloaded latest version of iTunes, ATv is updated to latest 4.3 (2557)


Seas0npass works flawlessly, but when I start up the ATv, it boots up normally. No sign of the jailbreak or Seas0npass. Even tried installing the 3rd party software, but nothing shows up.


Have not gotten any errors or boot issues. Tried to restore it twice back to back as people suggested. Tried other programs like greenpois0n, sn0wbreeze, pwnagetool. Have tried all of this on my mac running Lion and my PC also. Have tried running SP with and without the power cord. I’ve searched and searched, and tried a ton of methods. None of it works, it’s stuck in its factory state.



I bought this thing to jailbreak it, almost useless to me without it. If anyone has some advice, it would be very appreciated. Thanks.

When you JB with SP there is no visible sign that you have done so.

There are two ways to check:

  • install the ATV Flash Black. This will not work unless you have JB, and it adds the Maintenance menu
  • connect via SSH using root/alpine as the username/password. Again this only works if the JB worked. You can then do a manual install of nitoTV to get that added to the menus, and use it to install further items.

Damn, I feel like an idiot. Thank you.

I saw some screenshots of a Seas0npass menu and it tripped me out. ATv Flash worked great.

Glad it helped - I am sure that other people have been caught out by this.

Earlier releases of SeasonPass added a (temporary) SeaonPass menu item so it was more obvious. I assume this was removed because iOS 4.3 broke the method used to add the menu item. I hope they put it back in some future release, or at least set some visible indication that the JB has succeeded.

I’m having the same issue, but I guess I’m not as smart as the original poster.  I am not following the explanation.  Can you explain for “DUMMIES”.

I’m also having similar problems as the original poster, I have carried out the same instructions but I cannot SSH into the ATV nor can I see the icon on the desktop of ATV. please help…

My ATV version is (2775). When i use the SP client everything looks in order but the downloaded version is 8F455, is this correct? I have made sure I have the latest version of iTunes and SeasonPass. 

Ahh scratch my last post everything is now working, seems that before I was using an older version of SP. XBMC installed


Thank you…