Has anyone gotten the new seas0npass to work for ATV on iOS 4.3 (4.2.1)?


iTunes 10.1.2

Apple TV purchsed in Feb '11

Upgraded ATV to 4.2.1 (iOS 4.3) via iTunes update

Ran seas0npass version 0.7.3 (59)

Successfully entered DFU mode and built and installed ipsw file connected to laptop (MacBook) seas0npass indicated SUCCESS on ipsw creation/installation.

Successfully(??) teather boot (using key step: wait to plug in power cord until led flashes very rapidly) seas0npass indicted SUCCESS on teathered boot.


(USED Instructions here: http://forums.macrumors.com/showthread.php?t=1085555)


Switched out microUSB to HDMI and ATV comes up.

BUT...no visual changes to ATV

AND...cannot ssh root@

ssh: connect to host 10.x.x.x port 22: Connection refused


Has anyone actually gotten seas0npass to work with iOS 4.3 (ATV version: 4.2.1)?????

And if so, how are you verifying this?

Finally, if so, did you just ssh root@x.x.x.x doing nothing else, or did you need to do something else??

Same issue - followed same procedure with same outcome. Any ideas?

Scanning all the comments related to this blog post: http://blog.firecore.com/4209 (where they announce seas0npass now works with iOS4.3 (ATV 4.2.1)

Only 2 people with firecore accounts indicate they have been successful (there are a very small number of anonymous posts, 1 or 2, which I'm ignoring):

chadv.8696 (http://firecore.com/user/63893/track)

adamg.4951 (http://firecore.com/user/54879/track)

Here James, the moderator, suggests filing a support ticket if problems persist: http://forum.firecore.com/topic/3759

I'm going to do that, sending in my log file. Scanning myself through the log file, I saw 'Success' for both IPSW and Teathered boot steps in the interface, but I can't see how that translates to the log file.

Frankly, I don't think this works at all.

If it does work it would be interesting to hear success stories from more than 2 users.


Worked find for me, I put it in dfu mode the normal way but always used iREB to make sure

 it was before tethered with seasonpass.



1 other thing after I took the update,hooked the atv2 to the tv and set wifi, then JB it.

Not sure if it makes a difference but was the only way it worked for me.

Worked fine for me.  Running aTV flash (black) beta 4 and digging the new media player.  Also, ssh through terminal is working fine as I always change my password just in case.  I just followed the instructions from here:  http://support.firecore.com/entries/387605  

No problems here. Everything worked great apart from needing to create another account since Seas0npass does not work with FileVault. Used the directions posted on their site: http://support.firecore.com/forums/264862-getting-started

Would just like to say thanks for the hard work,
Seas0npass worked for me, love the media player

I have not gotten the new version to work. I purchased my at2 in early march ios (4.3.1). Ran software and it creates ispw. Ran restore through itunes using the created ispw but when I hook it back to tv no change. Any ideas?

Having problems as well......

running windows 7, apple tv 4.2.1., Itunes to final point of installing atv black and get message installation failed.Sorry, the installer could not connect to your Apple TV....HDMI and micro usb both plugged into device???

can't figure out what I'm doing wrong???

Same problem here.... Just downloaded latest version of Seas0npass and everything looks like it works but after restore, I unplug USB and connect power and HDMI, it logs in to a factory default apple tv but no signs of jailbreak

I've tried everything I was able to find on this site. I keep getting an error 21 code under Seas0npass for Windows. Anyone have any pointers on how to get the jailbreak working? Help please!

Forgot add this: I have no problem restoring original apple firmware under iTunes. I get the error only when trying to install the custom firmware. 



This is excatly my issue!!

error 21 is cuase ur not on DFU mode

Went through the whole process and no signs fo the Jailbreak after restarting the ATV2.   :(

I just got it to work. Had to use iReb to get into DFU and it won't look any different after you JB with SP. Only after you install ATVflash will it add the Maintenance Tab.

I am going to try again tonight when i get home but just wanted to check you can still get plex with Seasonpass ? If i can't get it to work may try a different jailbreak, really wished i had just kept 4.2.1 running greenpoison now.

the jb worked fine, but i have some problems with the xstream plugin. installation worked fine too, but if i want to stream a movie, xbmc chrashes permanently. on 4.1.1 everything worked fine with xstream. whats the matter?

Check my blog post, http://blog.mikegabriel.net/post/4387184206/apple-tv-2-fix-a-crashing-xbmc

For those who have gone through the process of running seas0npass only to find their ATV2 appears normal with no jailbreak, I believe this is expected behaviour.  The jailbreak installs sshd so you can remote in and install what you like.  I installed NitoTV which allows me to install XBMC and and a few other tweaks: http://www.sinfuliphone.com/archive/index.php/t-46007.html