Happy times are back! XBMC working again in 5.2!!

Just as this moment XBMC developer just post in XBMC official forums that XBMC is now working in ATV2 5.2. Happy times are back!




Now I know what to do on the weekend. :wink:

How to install?

The new version is now available via Maintenance > Manage Extras. :)

Hey i only recently learned how to jailbreak maybe 3 weeks ago when the 5.2 rolled out but i was having a hard time installing XBMC on that version and i must have jailbroken the aTV2 10 times bc i didnt know it wasnt compatible so my question is for me to update to frodo from eden should i also update from 5.02 to the newest version ?

Not necessary. If you’re on 5.0.2 and your happy like that, you can stay that way. BUT, if you want the new features in 5.2 (Bluetooth keyboard), then you should jailbreak again, with the incovenience of having to do a clean install of XBMC

yep! worked like a charm.

OK, some manual work. But it’s not that much and 5.2 is for me worth the effort.

  • select my AirPlay speaker as output

  • use multiple Apple IDs

  • Better PhotoStreams (Shared events)

  • Sort Icons


the option to install XBMC has not appeared in my “manage extras” section,can anyone help?

What do you mean with ‘some manual work’?

just updated and everything went smoothly. what I did notice though is once Itunes open season pass will automatically grab the wrong file(5.0.2), so I had to cancel season pass and manually select 5.2



I have xbmc in Manage Extras, but lost some apps as rowmote install.

That is because at this point these apps are not compatible with the 5.2 firmware.

This is why, when I rejailbroke several hours ago, I elected to go with fw 5.0.2, again. I  enjoy using Rowmote over the given ATV remote.

Can not wait to start on it tonight. ATV2

ATV3 still collection dust!!! 

Well, I had to add manually some xbmc plugins via zip files again and the generell settings in xbmc also.

I have not done the jailbreak for 5.2  I have updated via Firecore to Frodo 12-1 from Frodo 12. Most of my primary addons in XBMC work fine, however it seems that  1Channel is having connection difficulties.  I may re-install it to see if that helps. Do we need the re-jailbreak for 12-1 on ATV2 to work at its best? How would I go back Frodo 12  if desired. I tried using XBMC’s guide to reinstall most stable version which  on their site is Frodo 12. It installed on the ATV2, but IT DID NOT APPEAR ON THE ATV2 MENU . THe first boot was via the ssh install. I did a manual reboot just to see if it would make a difference. It did not. Thanks in advance.


In fact, you’re referring to 12.0-1, wich is a kind of special XBMC release for the Apple TV 5.2 and its new software structure, but it’s pretty much the same as 12.0, so you can stay there. So, if you haven’t jailbroken to 5.2, I think you won’t get 12.0-1. Someone can correct me if I’m wrong. Oh, and btw, 12.1 is due to June 2013

12.0-1 is what I am running. Installed via Maintenance.

Ok, so as I wrote. There’s no much difference between 12.0 and 12.0-1, so it’s up to you

XBMC v12 installed and working great on AppleTV 2 running OS 5.2. Huzzah!


Quick question though.  Whenever I try to exit XBMC, it either resprings (spinning wheel appears) to the original AppleTV menu, or it locks up and I need to force a restart.  Is this normal, or a bug?  Is there something we can do to fix it?  I’d like to be able to exit XBMC elegantly and go back to the original AppleTV menu when I am done using it.