Green block on widescreen movies

I am using FTP to transfer all the files from a DVD to a folder in the movies folder of the Apple TV. It seems like I am doing this part right as the name of the movie shows up on the Apple TV and I can start to play it - and the menu of the movie works just fine, but as soon as the main movie starts I get a giant green block in the black area of the widescreen.

I have tried this on two movies with the exact same results.

Any help greatly appreciated in getting this to work. I have the Apple TV hooked up to a Mitsubishi widescreen via HDMI. All original features of the Apple TV work just fine.

William.

You are the second person to report this problem. I will have our tech dept take look into it.

I have the same issue. ripped a movie using mac the ripper and ripped an exact copy. Loaded the VOB and BUP files onto a drive. when i selected the movie to play i first got the apple logo from boot, then the dvd menu. selected play and when the movie began i had this same green block on my screen on the top.

hi,

I had the same Problem, it is a NitoTV Problem, tried this —> NitoTV/Settings/Safe Display Release --> off

greetz guibaa

I tried every setting and it didn’t help me…

William.

Am I the only one experiencing this problem?

I’ve tried every setting I could find and nothing gets rid of the dreaded green block.

William.

What resolution is your Apple TV set to? Some users have experienced issues if they have it set on 1080p. Try switching it to 1080i or 720p.

1080i and 720p give the same green block, about half the width of the screen and as tall as the black widescreen band. In 480p the black widescreen band becomes half black and half green, on both the top and bottom of the screen.

William.

Hi there!
Entering these two Arguments in mPlayer Options solved the exact same problem for me:
-aspectratio
16:9

Although, there comes another problem with a different green block. On some DVD-files with menues the movie (not the menu itself) is squashed horizontally and on the left side, there is an even bigger green block. Already read about this in a different threat, but no help there. Also, the sub-menue items do not seem to work. And finally, the remote keymapping isn´t doing anything at all (yes, in mPlayer playback) I can only set the volume and chase through the chapters. Not to mention the occasional “flicker goodbye” of the atv, even in safe exit mode on my 1080i plasma.

The whole thing seems to be in beta.

Hoping the best,
Gero

Thanks for the help I’m adding the arguments in as two separate entries to mimic arguments that are already there:

-aspectatio
16:9

But now when I go to play a movie file it just crashes and goes immediately back to the movie list.

William.

The correct arguments are:

-monitoraspect
16:9

ups, very sorry!
posted out of my memory, just checked, the right argument is
-monitoraspect
16:9

Gero

edit:
you guys are fast :smiley:
did you encounter any of the other issues?

Hi again!
Funny thing, my atv suddenly doesn´t play any DVD-files on my ext. HDD. Didn´t change anything to the former working state, it just freezes on selecting the DVD. Already did a reset and patched it again.
Considering the numerous posts on faulty behaviour, I guess the team is working hard on an update, but since I paid for an working product, I am thinking hard about the refund thingy.
Would be nice to hear that you guys are on top of the problems.
bye
Gero

Have you recently unplugged the hard drive? The best way to ‘eject’ a USB drive is to power off the Apple TV then remove the drive. We’re planning to implement a more elegant solution in the next version.

unfortunatly, I tried every combination of plugging and powering.
Hotplug, boot and plug, booting plugged.
just entered the next stage, Nito does not even go into the “file” submenu.
Sapphire on the other hand sees the hdd and the movies. Playing is of course not possible.

dark magic! :lol:

Unfortunately all that did was move the green block to the left side of the screen.

William.

Hi William,
guess I solved it.
In mPlayer Arguments please delete the former mentioned
-monitoraspect
16:9

the right arguments would be
-aspect
16:13

here´s the trick (basically):
The movie is stored in 4:3, the TV stretches the pixels to match 16:9.
You have to tell mPlayer the right format of the source. That would be 4:3 or 16:12. Still, on my TV, there is the overscan issue. So I tried a little bit and found the right ratio to fill my screen. So maybe you have got to try different setting for yourself, but that´s the way to go.

Anybody:
Does keymapping (for example cycling through audio tracks) work for you?

Gero

Entered the arguments and still got the green bar; only thinner. However, when I turned off the use DVD menus the bar went away. Would be nice to have a solution where I could use the menus.

well in reading the follow ups to this i tried many different arguments and what I found that worked on my 32" tv is
-aspect
19:13

its an interesting ratio but in my situation it works like a champ, granted only tried movies that are widescreen. it will be interesting to try this on movies that are 4:3. anyways. keep up the good work fellow aTVers and please post the ratio’s that work on your tv and size of tv.

Yeah…

I’ve got a 52" Sharp Aquos 1080p LCD.

I did the 16:9 thing.

It did two things.

1, when watching movies on a DVD file with menus enabled, it moves the green block to the left.

2, when watching movies on a DVD file that’s just the main feature, menu’s disabled, the image is perfect.

I’d like to rip my DVDs and keep the menu’s intact, but it doesn’t look like that’s an option right now.

If anyone else finds an aspect setting for a 52" 1080p TV that works better than what I’m using post it up.