Gradient / color banding

Hi,

I have a 4k hdr tv and an Apple tv 4k.

One thing I see is that there is way more banding with Infuse than Plex client.

This is an example. Note that I boost the exposure on my phone while taking pictures so it’s more visible that way.it

When I play the same scene with my plex native client, the image is better.

When watching tv during the day, it’s not that distracting but during night in darkness, it’s impossible to miss.

Thanks

Do you have match content enabled? Is this SDR video or HDR video files?

All HDR.

SDR seems to be ok!

I’m matching content and the TV do switch to. HDR10.

FYI, I don’t have this problem using Netflix in dolby vision. Seems to be HDR10 files only and it’s worst with Infuse.

Very strange. I don’t have the issue with HDR10 content on my TV. I’m using an LG OLED with the technicolor profile enabled.

Looks like it’s not switching to the right colour space, what Oled do you have is it a LG B6 by any chance I remember having issues with hdr not switching properly and would get terrible banding, I think LG fixed it with their latest update. I have a B8 now and all works fine.

Not OLED, it’s a LED (Vizio PQ65)

Ok I did more tests. I can confirm you that using the original Plex client on Apple tv OR on the internal app of the tv, I don’t have any problem.

I only get the problem with infuse on my Apple TV 4K in HDR…

It’s only happening with dark colours. Bright scenes are OK.

I really love Infuse but I think I’ll be forced to switch back to original Plex client if it’s not solved :frowning:

We have a few changes coming in the 6.0.7 update that will address a few reports of this.

To get a better sense of what is going on in your particular case, would you be be able to send in a report from your Apple TV then next time this happens?

I can reproduce this very easy with any HDR10 movie with dark scenes. How should I do this ? I play a file with this problem then I click the “Send diagnostics” ?

Maybe the same as this(?): HDR Tone Mapping ALGORITHM

That’s a different issue, HDR on a SDR TV, the person above is viewing HDR on a HDR TV.

problem still present with 6.0.7…

1 Like

This seems to be a configuration issue with the PQ65, as another user is seeing something similar here.

We don’t have one of these TVs here, but you may try one of these suggestions.

  1. Reset Apple TV settings and change Apple TV Chroma to 4:2:0
  2. Try a different HDMI cable
  3. Try a different HDMI port. It looks like HDMI-5 may be some sort of special low-latency port which is not recommended for HDR. It seems HDMI-1 with UHD color enabled is the recommended port for HDR. https://www.bestbuy.com/site/questions/vizio-65-class-led-p-series-2160p-smart-4k-uhd-tv-with-hdr/6213228/question/e0a69e5e-113f-38d9-9d4b-245e66cb2864 and https://youtu.be/BsoFjzZZLdo?t=83
  4. Try adjusting the dimming settings to see if there is any change. A few screenshots from various settings can be found in this post. https://www.avsforum.com/forum/166-lcd-flat-panel-displays/2991586-2018-vizio-p-quantum-65-pq65-owners-thread-no-price-talk-16.html#post56584544

I returned the Vizio last week and I’m now with a Sony X950G and I’m pretty sure the problem is still there but let me do the test again tonight.

Btw it still works great with native plex client.

I just tested again on my new Sony X950G.

Exactly the same problem, not happening with Plex client with same tv picture settings

Do you have dynamic contrast or any other picture enhancement settings enabled? These enhancements are notorious for making a picture shitty.

no but even if I did, it works well with Plex client. It works well with VLC. Infuse is the only one giving me problems

AFAIK, neither of those apps fully support HDR output, so what you are likely seeing is some sort of SDR downsampling.

Have you had a chance to try the suggestions above for chroma, HDMI input, and HDMI cable?

I tried 4-5 differents HDMI cables, including the Belkin recommended by Apple. They were all 18gbs certified cables except the Belkin which is a 48gbs cable. No change.

HDMI input were tried on all HDMI ports supporting full 4k HDR on the Vizio (hdmi1-4) with no difference. Now I have a Sony and I tried it on two HDMI ports with the exact same result.

I’ll try the chroma again, which didn’t make any difference if I remember correctly but I need to confirm.

Also, on the 950G it looks like you’ll want to enable ‘Enhanced Format’ for the HDMI input you are using, as this is disabled by default.