Go through booting sequence after boot video goes black, does nothing

so i went and was gonna check the weather under the nito tv menue drop, it said an error occured and told me to press the play/pause button to reboot… i tried several times and waited for 5 min, also tried pressing and holding it, tried everything i could do and it wouldnt reboot buy pressing the play/pause button. so i decided to pull the power plug and reboot it that way… it went through the apple screen than the animation, than after it goes black when its supposed to load the menue, i thought maybe it was being buggie and waited 10 min thinking maybe the menue would load it didnt. i could press the buttons on my remote and it made the sounds but no visual, absolutley nothing. ive had firecore on it for 5 days and it was working but lots of freezing and really buggy. i bought a new apple tv 1st gen 160gb last month i hardly let it run for more than 3 hours at a time and always shut it down, it cant be a hardware issue… if anyone knows what to do please help