Getting the aTV2 into DFU Mode never works

I’ve tried every single thing that I can read about how to get this working and it just won’t ever get into DFU. 

I’ve tried different versions of iTunes (11, 10.7, 10.6), no difference. It’s almost like my appleTV is never even seen by the computer, but it is getting some lights blinking.

Any suggestions would great. 


2013-02-09 11:25:57.628 Seas0nPass[1626:207] __CFServiceControllerBeginPBSLoadForLocalizations timed out while talking to pbs

Try with the power cable

are you sure its a apple tv 2? is the model A1378?

Yes, it’s the Apple TV 2 Model 1378


When I leave the power cable in and go through the process, I get the rapidly flashing light, but it doesn’t stay. As soon as I switch from pressing Menu + Down and move to Menu + Play/Pause, the rapid flashing stops.


Try this it worked for me.

Start Seasonpass and let it’s do it’s thing until it asks for device in DFU mode.

Plug in your atv using micro usb /usb to your mac.

Plug in power on atv then quickly press the two lower buttons on your remote for seven seconds. Rapid blinking indicates that it’s gone into DFU mode and Seasonpass will indicate that it’s now working.

Quickly remove power cable.

Let seasonpass and Itunes do the rest.

This worked for me. The key is to remove power when rapid blinking starts quickly.

Ok, I’ll try it and report back.

Just curious, were you able to see your AppleTV in iTunes before you ran Seas0nPass? Because iTunes won’t even recognize my AppleTV.

Should be getting this cable today

Going to try out the latest Seas0npass. Noticed somewhere else you got to make a change for it to work.

UPDATE: It was the cable! James really needs to update the Jailbreaking 101 ( ) with that Amazon Basics cable instead of the Belkin crap, Amazon’s worked like gold.


Just a note for everyone go has been running into the 5.2 update issues. If you’re still having problems running seas0npass do this:

For anyone struggling with the "filesystem patches failed" error, follow arpena's advice below for a fix.

arpena wrote:

It's a bug in Seas0nPass. In Mac OS X 10.7 and up, tar changed its behavior not to follow symlinks when restoring files. Ironically, it is the same bug evasi0n exploits in iOS MobileBackup to make the jailbreak untethered.

See my previous post:

You can download the modified evasi0n.tgz from to solve the problem. Replace your\,1_5.2_10B144b.bundle/evasi0n.tgz with this file and post here the result.


Thnks for the help, daw. New cable did it!