get back your boxee

ill try and help out

I believe i have found some useful information at However I will tell you this method is incomplete.  I did not have root access after i went through this process and was unable to transfer the back to the ATV.

I have just started over from Factory Restore and plan on using ATVFlash and try again.  I’m hoping that I will have root access afterwards, but I just don’t know enough about it yet.  Perhaps I don’t have root because I changed the root password and forgot before the factory restore, but I would think that would have restored all of that.  Once I have completed the install tomorrow, I will post step by step on these forums.

what if i use window ? i dun have mac 

Hi , I followed the instructions and got boxee under application in nitotv.

how can i get it to main menu?

it keep crashing as well…


Installing boxee on ATV 1st Gen

I finally decided to bork my ATV and start over to see if boxee beta can be installed on the atv even though Launcher will no longer download and install. The good news is that I was able to install boxee relatively easily. Instructions are in my signature, the big difference is that you ned to manually install the into the root /Applications folder NOT ~/Frontrow/Applications.
You may need to update permissions, but I can and will post instructions to this thread later tonite.

I still suggest you use XBMC, but for those who love boxee beta, its good news.

Update: Overview (Detailed are in my signature)

  1. Factory Restore (Assuming you have to). - Once restore update to 3.0.2 via GENERAL>UPDATE SOFTWARE.
  2. Run Patchstick (Im assuming you know what this is) - Latest please !
  3. Once re-booted into the familiar Frontrow, Update to Launcher 3.2.5 from LAUNCHER>DOWNLOADS.
  4. Install NitoTV via ssh (Terminal or puTTY) - See my signature.
  5. Once Frontrow Reboots, Nito appears. Run Smart Installer (It will download the 10.4.9 dmg) - Needed for USB access.
  6. Copy OS.dmg (coreaudio) into ~/Frontrow/Documents. Run Smart Installer again. AFP, FTP enabled now.
  7. Download and unpack boxee beta on your mac (see my signature). Using sftp (cyberduck) copy into the root Applications folder; /Applications NOT NOT NOT ~/Frontrow/Applications.

If you receive a permissions issue, ssh in and issue the following;

sudo mount -uw /
sudo touch /.readwrite
sudo sync

Try again. Should be 775 or 777.

You can install Flash from Nito. Install XBMC. You can Run Boxee from within Launcher. It will create its own userdata folder.

Its a good idea to have the recovery.dmg installed within Nito and install OS.dmg. In order for flash to be installed from nito, you need to have the coreaudioframework bits installed, which are thankfully provided by the recovery.dmg that gets installed from within nito.


dont forget to do the permissions part you can use winscp(its for windows)  you login in with your ip address and the user name frontrow password

frontrow then the boxee app has to be in your root folder then right click the boxee app and set premissons to either 775 or 777 then it will upload the boxee app to the right spot and then you can launch boxee threw the launcher there isnt no more a boxee menu its  in the launcher menu

Finally success.  I’m not sure where my glitch was but I have finally got it all worked out.  This process is from scratch so I will start from a fresh factory restore.  It shouldn’t be too hard to start later on if you don’t feel like the restore.


Boxee Install on AppleTV (1st Gen - White)

First things first, lets get that ATV write enabled, saving you a lot of hassle in the end.  This only needs to be performed once.


Make ATV drive write enabled:

  1. sudo mount -uw /
  2. sudo touch /.readwrite
  3. sudo sync


Tools/Downloads needed for this project.  These links are also included as the steps requires them, but I like to download it all at once before the project requires them.:


Cyberduck:  - NOTE:  Now featuring a Windows client


Note:  Method 2 is for those who wish to start all over from a fresh install and get Boxee in the process.


Method 1:  Manual install

1. Download the latest Boxee Beta from (Dropbox link, Mirrors to come) on PC/Mac

2. Using Cyberduck (or other SFTP client) ( login to ATV

  • Connect to: AppleTV.local
  • Username: frontrow
  • Port: 22
  • Directory: ~/
  • Password: frontrow

3. Upload to ~/ (This is the Users/Frontrow directory)

4. Open Terminal or other SSH app and type the following (without quotes)

5. ssh frontrow@appletv.local

6. Enter frontrow as the password

7. sudo mv ~/ /Applications/

8. Enter frontrow as the password

9. Restart Finder or Reboot (unplug ATV...plug in ATV)



Method 2: From Scratch - Factory Restore

1. Press and Hold - and Menu buttons on Apple Remote until Amber light flashes, then release.

2. Once ATV boots, select your language and then select Factory Restore

3. Now that you are fresh, select Settings and then Update your ATV

4. Once updated proceed with the ATVFlash Process:

  1. Insert ATVFlash USB drive
  2. Unplug ATV
  3. Wait a few seconds and plug ATV back in
  4. Let ATVFlash do it's thing (Thank you Firecore)
  5. Once ATVFlash is finished, remove USB drive and unplug ATV
  6. Plug ATV back in

5. Download the latest Boxee Beta from (Dropbox link, Mirrors to come)

6. Using Cyberduck (or other SFTP client) ( login to ATV

  • Connect to: AppleTV.local
  • Username: frontrow
  • Port: 22
  • Directory: ~/
  • Password: frontrow

7. Upload to ~/ (This is the Users/Frontrow directory)

8. Open Terminal or other SSH app and type the following (without quotes)

9. ssh frontrow@appletv.local

10. Enter frontrow as the password

11. sudo mv ~/ /Applications/

12. Enter frontrow as the password

13. Restart Finder or Reboot (unplug ATV...plug in ATV)


That did it for me! I hope this helps others.



Great help folks. Thanks. When the brand new product called Boxee TV has been released on the market, I found it worth looking for. My expectations have been met and I really love my new TV right now. It saves me a lot of penny in paying my monthly cable. Read more here

I have tried all the steps above but I cant ‘SUDO’ those commands to my apple tv??? How? I have Cyberduck and I can connect to the ATV1 but how do I run the commands? Is it through a seperate program??

in terminal