Generated thumbnails missing for Dropbox

Hi. Last week I noticed that newly added videos do not have generated thumbnails. I tried refreshing metadata, deleting cache and finally today I deleted everything withing Infuse and reinstalled the app. Upon adding network storage, I went into “Library” menu and noticed that there was a progress generating those thumbnailes but that progress seemed too good to be true, it took 2 minutes to generate thumbnails for ~3000 videos and cache size is too small. Now when I open the homepage and any category from there, there are 0 thumbnails visible at first, and if i sit on the page long enough, they slowly starting to show. This happens both on Mac and Apple TV. Is there a fix for this issue?

What type of device are you streaming from?

Are you browsing via the Library or directly via folders?

Can you navigate to Infuse > Settings > General and check what the following two options are set to?

  • Metadata Fetching - ON is recommended
  • Embedded Metadata - OFF is recommended

You may also check the share’s setting and see what the ‘Pre-Cache Images’ option is set to. With this off, Infuse will not pre-cache any artwork and instead will fetch images on-demand as you browse to various sections.

Hi. I’m mainly using Apple TV 4K (2022) but the issue occurs also on Macbook. I’m browsing via the Library. I just checked the settings you mentioned: Metadata Fetching is set to OFF, Embedded Metadata is set to ON. Pre-Cache Images is set to ON. That’s the way I’m using Infuse for private videos, there’s no data to fetch so I want to see generated thumbnails.

Got it.

In that case, Infuse should be generating these images for you automatically.

This is a relatively slow process, and the status shown on the Library page for this will be ‘Fetching details for xxx’.

Yes, that’s what it was doing before. As I said in my OP, “I went into “Library” menu and noticed that there was a progress generating those thumbnailes but that progress seemed too good to be true, it took 2 minutes to generate thumbnails for ~3000 videos and cache size is too small.”.
I tried re-adding the share and after “Fetching details” it changed to “Generating thumbnails” but again, the progress was too fast and in the end there were no thumbnails generated.

Here’s a screen recording of this process, unedited: Transfer - Dropbox

Thanks for the video.

It looks like this is a Dropbox share, and when connecting to a cloud service (like Dropbox) Infuse will not generate thumbnails for your entire library in advance.

The reason for this is all cloud services have API limits in place, and generating thumbnails is a very API and bandwidth intensive process that will often times lead to a temporary ban. As a result, Infuse will generate thumbnails on-demand while browsing when using cloud services.

Ok, got it, thanks for the info! I thought it was something else because they were generating in the past, even for Dropbox and Onedrive. I remember I had to disable sleep timer on Apple TV because it took over an hour.