G Suite "Download Quota" API Ban

hitting the ban for months(since v6?); started using other progs, but like the subtitles ez lookup for infused and it’s better player; glad i came back to check this thread; turn on legacy mode, await the exceeded error to clear (i always give infuse a few try after installing beta) and give it try with the legacy mode.

Hi @james - just checking on the status on this one. Thanks.

It’s still in progress, and at the top of our list. :slight_smile:

2 Likes

Thanks James.
I like to add it’s really needed. Google Drive streaming was the main reason I purchased my lifetime license :slightly_smiling_face:

In the past two weeks, regardless of any version of Pro, I cannot access the videos of Google Drive


No matter it is APPLE TV/APP, it is unavailable and will display an error
At first I thought it was a problem with my Google account
The source of my account is normal, there are normal payments, the space is 5T, and it will be used normally within 2 years, and it can also be downloaded/uploaded.
I think infuse will cause Google to misjudge

When it shows that the download exceeds the quota, you have to use it again after 24 hours. It is basically a bug. I download directly from the web page and it is no problem. The access through the software is locked for 30 minutes

firecore please hurry up to debug and solve the problem, I have been using Pro6 for two weeks, it’s a really bad experience

I’m from Taiwan, and my English is a bit bad, I hope to solve the problem

As long as there is a download behavior with App/TV, Google will block it, but the download traffic does not exceed the limit at all, because I can download directly from the web page
未命名

Hi James! I really appreciate your effort to fix this problem. Would you have an ETA on the fixes release? Thank you!

there’re very similar issues when using Infuse’s Emby client.
When pausing a video and resuming it, Infuse requests the (Emby) source again
GET /Videos/12345/stream…

If this is external content you also run in ban problems as descirbed above. Why doesn’t keep Infuse the connection alive while pausing?

as far as I can tell the scrobble preview is also a problem for this type of content as it touches the source again and again when you get preview images of unbuffered areas. So an option to disable this feature would be helpful.

btw other clients do not behave that way. Official Emby client on tvos e.g. doesn’t fetch the source again after pausing.

Hi, I know you have busy days right now because of the mac alpha, but is there any progress to announce on this issue?

recent infuse update is driving totally crazy about video url requests from emby server.

[27/Dec/2020:10:41:17 +0100] "GET /Videos/335822/stream?MediaSourceId=xxx&Static=true HTTP/1.1" 
[27/Dec/2020:10:41:27 +0100] "GET /Videos/335822/stream?MediaSourceId=xxx&Static=true HTTP/1.1" 
[27/Dec/2020:10:41:35 +0100] "GET /Videos/335822/stream?MediaSourceId=xxx&Static=true HTTP/1.1" 
[27/Dec/2020:10:41:41 +0100] "GET /Videos/335822/stream?MediaSourceId=xxx&Static=true HTTP/1.1" 
[27/Dec/2020:10:41:48 +0100] "GET /Videos/335822/stream?MediaSourceId=xxx&Static=true HTTP/1.1" 
[27/Dec/2020:10:41:58 +0100] "GET /Videos/335822/stream?MediaSourceId=xxx&Static=true HTTP/1.1" 
[27/Dec/2020:10:42:07 +0100] "GET /Videos/335822/stream?MediaSourceId=xxx&Static=true HTTP/2.0" 
[27/Dec/2020:10:42:15 +0100] "GET /Videos/335822/stream?MediaSourceId=xxx&Static=true HTTP/1.1" 
[27/Dec/2020:10:42:23 +0100] "GET /Videos/335822/stream?MediaSourceId=xxx&Static=true HTTP/1.1" 
[27/Dec/2020:10:42:37 +0100] "GET /Videos/335822/stream?MediaSourceId=xxx&Static=true HTTP/1.1" 

Hope that’s not intended? This is while normal playback…

How many movies on that day?

At least 8… but I don’t quite remember at this point. But haven’t had the error since thankfully :crossed_fingers:

•••EDITED FOR LANGUAGE••• got worse. Please fix.

Hi @james - since we have not heard from you in some months now (almost 3), I would like to know the plans to deploy the fix for this problem you mention you were working on. Thanks.