FYI - How to successfully install Adobe Flash on ATV Flash 4

I’ve found a bunch of posts, and searched through the wiki for a proper way of installing Adobe flash on ATVFlash. After a lot of experimenting, I was finally able to do so. I’m outlining the details step by step (this is for ATVFlash 4.0 with AppleTV 3.0 installed.

  1. Force factory boot (hold “menu” and “-” key down on remote for 6 seconds). ATV reboots into “safe mode”
  2. Select “Factory Restore” (had to do so because I had botched a couple of Adobe Flash installs).
  3. Accept restore, let restore complete. Select language and network settings after reboot.
  4. Once ATV menu appears, update ATV software to 3.0 (Settings - General - Update Software).
  5. Install ATV Flash software on ATV
    NOTE: If you are using a flash drive you previously used to update your ATV with a version previous to 4.0 - you MUST reformat it before trying to install version 4.0 to it, otherwise, it’s probable bootup sequence will just be in an eternal loop. Instructions can be found here on how to format drive:
  6. On your ATV, go to Maintenance - Settings, and select nito.SmartInstaller. Click on this and allow for your ATV to download and install.
  7. Get a copy of coreaudiokit.framework. Since I have a Windows machine, I don’t have tiger OS install disks, so I was able to find a torrent with this (it’s on one of the most popular torrent sites - one which has been sued bigtime as a matter of fact).
  8. The file has various folders, Take one of them (CoreAudioKit.framework) and via FTP put the folder and ALL ITS CONTENTS in your ATV’s Documents Folder.
  9. On your ATV, go to Maintenance - Install Extras, and select Adobe Flash. Let the sequence run and it should be successful.
  10. Check that in Maintenance - Manage Plugins, make sure internet says “Enabled”.

My big confusion was that I would install NitoTV through the NitoTV menu, and here there was an option for Adobe Flash installation. It would fail (but when I checked later it would say successful) and no matter what I did after that, the Adobe Flash install from the Maintenance tab would never work.

Hope this helps someone avoid some frustration. Oh and cheers to the ATV Flash developers… you guys rock!!

Got the files, cheers Sole, followed your guide to a “T” and still no joy.

FTP’d back into ATV and the coreaudiokit.framework folder was missing, added again, installed flash through maintenance, said dependencies were installed.

FTP’d back again and the folder was gone again!

this thing is really pissing me off now! this is the main reason i bought this software and i’m not happy! :evil:

Cheers for the info though Sole :wink:

Just to add to Sole’s info.

i couldn’t get that to work, but what i did was the following.

download adobe flash for MAC OSX.

dumped it into the applications folder via FTP

dumped the coreaudiokit.framework into the documents folder

went to ATV, clicked on maintenance, install extras and selected adobe flash.

it then found and succesfully installed adobe flash.

then i went to firefox, found a site with flash running (BBC iPlayer) it then picked up i had a missing plugin

installed that and then all is hunky dory!

got 4oD and BBC iPlayer working now :slight_smile:


I followed yours to the T and did the same thing… I got to a site where it said I had a missing plugin… I click on it and it went to install… I followed through … then it went to the black screen with an apple… and it stayed there forever… I waited like 5 min and not being patient i never waited for it to come back to FireFox. How long does that take? Should I have just walked away and let it do its thing. I mean 5 min seems like a long time… Any thoughts?

hello mate,

When i installed the plugin, iirc it stayed in the browser.

have you done a complete restore? then installed ATV Flash?

i would suggest if you haven’t already, to basically start from scratch with a clean install etc.

tbh, i spent about 3 hours fiddling with the folders etc trying to get the coreaudikit.framework file into the right place with no luck. when i did finally give up and checked my aTV i tried to install flash one more time and it worked?! then i went to my browser and pointed it at BBC iPlayer and it said the plugin was missing, reading other guides on the net (nitotv’s wiki for e.g) it states you need to have the plugin in the correct folder as well. the browser helped me out by filling that bit in for me.

as i dont have a Mac it was seemingly difficult to SSH into my box to put the files in the correct folders due to privileges. the main core things from memory you need are, the coreaudiokit in the correct folder, adobe flash in the right folder, then install everything etc.

tbh judging by the piss poor lack of support on this site (that we pay for btw ATV Flash!!!), then please feel free to email me again if you still cant get it to work.

i’m very eager to make sure the process works as i will eventually need to upgrade my aTV and ATV Flash and i dont want to spend the best part of 18 hours figuring this out again!


Hey Nick,

Yea I have gone from scratch like 6 times today. MAybe even more. I have restored to factory. After restoring to factory I wait for the update to download. After it downloads I update the ATV. After the ATV is updated I put in the thumbdrive with the latest ATVflash and reboot. ATVflash installs. I reboot. Then I go to Maintenance - Settings, and select nito.SmartInstaller. Click on this and allow for your ATV to download and install. After this is installed I reboot. Then I go into FTP> I put the CoreAudioKit.framework in the Documents folder. I am about 99 percent sure i have the correct folder because I received it in my email from someone on this site that got the flash to work. I then downloaded the flash for MAC os like you said and put it in my application folder where it still sits. I think go back to apple tv and maintenance and go to Adobe and Install. I then install FireFox and reboot after this. Success it says. Then i go into firefow and went to Says I have an outdated version of Flash and I need to install a new one… And then there is the yellow box just underneath address bar that says missing plugin. I click on that and it says the missing plugin is Adobe Flash and gives me the option to install. I click yes and agree to the EULA. then I watch the bar install and it reaches the end. THen the screen goes black and the apple picture appears. And then it just stays there… Yellow blinking light. So i am stuck. It might be my Core Audiokit folder… IDK im just frustrated like crazy. Cant believe they advertise that this is easy and can do all these things… sheesh…

Am I placing what i said in the correct folders?


My firefox is not stable and crashing after I do the above. Not sure why? Once it goes to install the missing plugin it must hang up somewhere and just holds at the black screen and apple. I click menu to back out and then click firefox to go back in and it will ask me if i want to restore previous session or start a new one… I have clicked both and nothing … Still hangs up on the Firefox. Anyone have any ideas… Many hours here and still not working…

after installing the smart installer, i also installed firefox at this point (also air mouse but i dont think that has any bearing), then i did al the stuff with dropping flash into the apps folder etc.

one thing i do notice is when you drop the CAK (Coreaudiotkit) into the documents folder, if i then reboot the aTV it removes the file as it tries to move it to the frameworks folder but fails. just make sure you get all the necessary files in the right place, get the firefox installed, go dump the CAK file into documents then get adobe flash installed (making sure it definitely says “adobe flash has installed successfully” or some such phrase), then go to FF go to the site you said about and install the plugin.

the other thing you mention is that site stating you have an outdated version of flash, i never got that, i downloaded the most recent version of flash from adobe. that may have a bearing? i only got the plugin thing, made sure it was going to the right folder for the plugin, cant remember off the top of my head but think it was the plugin folder under the system files funnily enough lol. i honestly dont remember what my browser did after installing but i dont think i got the black screen, think it installed and maybe rebooted to the finder but i think it might’ve stayed in the browser and just said install successful.

try the BBC iPlayer website if you can, purely because i know it worked for me through them but not the channel 4OD site which i tried first.

my firefox also hangs like a bitch if i go into after switching the aTV straight on. i find if i launch it once the aTV has had a minute to gather itself then its ok.

and your comment about ATV Flash, one word “agreed”!

Ok here is the latest…

I started with the factory restore again. After the restore I updated the ATV. THen I installed ATV Flash. I then installed FireFox. After I installed FireFox I put the CoreAUdioKit in the Documents Folder. This time I didnt install Adobe Flash but went to a FLASH site on FireFox… At the top of FireFox it said I was missing a plugin. I clicked on that and it was Adobe Flash plugin. I clicked on that and it installed without problems. Sweet I thought. Then I went back to the FLash Site but still wasnt able to watch anything. SO then I backed out and went and installed Adobe. Successful it says. I went back into FireFox and went to a flash site and now FireFox is unstable and just hangs up again on the black screen with the white apple. LMAO Any thoughts… Anyone have what they say is the correct CoreAudioKit and mind emailing it to me. I have what i thought was the correct version but you can tell in the folder …

Someone has to know what this problem is…

Oh one other things, I can click on install Adobe in firefox and it will save or open it… What kind of program is needed to open the .dmg file to start the install…?

can ATV admins add anything to help???

Hi there

I’ve tried to follow the helpful steps provided but couldnt get past the point of installing ATV flash on the ATV. My APT was first gen, so it’s restored it to version 1.0 of the software. After I installed ATVFlash, I don’t seem to have any of the previous menu options I did last time I installed it, such as maintenance, NITO, etc. All I have actually is Saphire. I’m assuming that this is because its only v1.0 of the software??? I didn’t update the software cos I figured that the upgrade to 3.0 had caused such pain with ATVFlash (losing couch surfer, etc) that it might be best not to. Didn’t realise that v1.0 might cause me problems!

Anyways, can’t seem to get the ATV to upgrade its software. I go into settings and look to ‘update software’ - but there is says there is no update available. Which clearly is not true! :slight_smile: Any ideas how I can upgrade the ATV, which I’m assuming is the key to solving this!


Flash is working now… I currently am connected to the internet via the WiFI and it is choppy. I am hoping that is the problem… You honestly need to have all the right files. I followed Millsy8 exactly and it works… i didnt work before but today it is working…

I am curious on some other things but I will post a new topic on that…

So when will we see Crystal HD running on aTV? Adobe has prereleased Flash w/ support for BCM70012 card AND Broadcom has provided updated driver (for Windoze) Linux support is being open sourced so drivers are evolving (see

Trust me, Crystal HD (BCM70012) will great rid of those jitters, but at loss of your wifi card. So run an old fashioned RJ45 cable and stream your 1080P.

Yeah, Baby!

Glad you guys found this useful.

i had to do a restore the other day, and although hit and miss i managed to get flash working again.

the main thing to do is make sure you have the coreaudiokit.framework file. i managed to install adobe flash via the install menu, even managed to update firefox to a newer version.

as said video is choppy tbh.

i’m considering getting a Wii tbh as all i want is a browser and BBC iPlayer, i can do without the music and movies tbh as i own a Blu-Ray player and xbox 360 with the sky player so i get my movie fill from those.

I was able to get the Flash player working by following the instructions in this thread as well as the ATV wiki page covering Flash installation. No real problems, it came up first time. That said, playback is poor. I used Amazon’s VOD service to test the installation. The playback app for VOD has a network bandwidth indicator which indicates that I’m getting the same network throughput on my ATV as on my PC, 1328 kbps. On my PC the playback is smooth. On the ATV however, it’s very choppy. I’m guessing that since the network throughput is up to snuff that the problem is with the processor used in the ATV. The Wikipedia page on the Apple TV, as well as Amazon’s VOD minimum CPU specifications, bear this out. This indicates that the ATV is not a good platform for playing Flash content. I get similar results with video content on Hulu.