FTP Stopped Working

Hello, FTP has stopped working for Infuse for my iPhone, but our ATVs and iPads have no issue with it. It started 4 days ago just on my iPhone.

I can use SMB but it’s created duplicates of all my content on the other devices.

1 Like

Let’s hope SMB does the trick.

1 Like

Both ipad and apple tv apps (infuse pro 6) can’t play video from NAS. Thanks guys, for you “improved FTP connection”
infuse 5 still working

1 Like


As a first step, can you double-check to ensure the correct username and password are entered for this share? 6.0.7 included a few fixes for how these are saved, though in some cases these may need to be re-entered.

If that doesn’t help, and you have a moment to send in a quick report from your device, we’d be happy to take a look.

Can you check the address field and see if it’s correct?

As of right now, I have FTP working. This is after days of troubleshooting and talking to email support. I appreciate the help they give, but nothing resolved my issue. They told me to just use SMB. I tried to just use SMB, but I was still getting buffering issues with 4K.

I would sign into FTP through “Available Shares>Media(FTP)>then fill out my information>” My content would show up and collect metadata, but would error out whenever I tried to play it. I tried uninstalling the app and everything I’ve read here and everything that was suggested to me, but nothing. One thing I noticed is that my address under the FTP setting would keep changing to “homemedia.local.” No matter what I tried, it kept changing to this. Finally, I went to “Others>Protocol FTP” and it stopped changing my address and my FTP content started working. It’s been about 18 hours now without any issues. But man, Infuse has been a bag of issues since updating to the 6.0 update. I’m not only dealing with my own stuff, but my family and friends who I talked into subscribing to Infuse, which makes it more frustrating.

Also, I had to turn off iCloud sync. I can’t get FTP to work with that on.

On a positive note, with FTP working, I haven’t had the issue with buffering that I had with 6.0-6.0.6, my folders are loading much faster, icons are displaying as I scroll, instead of slowly loading in, and BDMV folders and ISO’s are loading very quickly. So there are definitely some improvements, but they can mean little when you can’t play your content.

1 Like

Sorry, there’s an issue in 6.0.7 which is affecting FTP in some network setups.

We’re working to submit a fix to Apple ASAP.

Thanks for the reply, James. If this helps, if I had iCloud sync on, the name would get changed to homemedia.local, after a day or so. Without iCloud sync on, it doesn’t change on its own. I forgot to turn iCloud sync off on my iPad and kept having this issue, but not on the devices that sync was disabled.

Also, I always used the ip address. I’ve never used the dns name with FTP.

Looking forward to the fix.

The fix for this is available in 6.0.8 which was just approved, and is now rolling out on the App Store.

Thanks for your patience. :slight_smile:

Hey, I’ve got basically the same problem as OP with using FTP to access my NAS on infuse 6. Can’t seem to be able to solve the problem.

Basically, when I set up the FTP connection, I am able to access my NAS through infuse, infuse downloads metadata of movies I have stored there, but whenever I try to play any, it just loads for a minute or so and then says that there was an error accessing the movie file. After that, I cannot even see the video files on my NAS with FTP, as the infuse just says that there was an error. That last error disappears only after I restart my apple tv (but reappears if I try to play any video again).

I can play video files fine with SMB, but I have somewhat old NAS unit and it only supports legacy, which is (I guess) why it buffers a lot on larger 4k files.

The thing is, to this day I am able to use FTP without any problem on Infuse 5. The obly problem I have with using ftp on infuse 5 is that whenever I try to use ftp on infuse 6, try to play a movie there and subsequently get the “there was an error” message preventing me from accessing nas by ftp at all, it says the same thing in infuse 5. It´s fixed by restarting apple tv.

Any thoughts? I have been trying to fix this for the last couple of days without any success. Thanks

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.