Frustration has set in - iFaith won't dump blobs!!

So I have Jailbroken my fair share of Apple TV2’s over the last few years. As of today I can’t get iFaith to dump any blobs from 3 different 4.4.4 virgin units or a used 5.1 unit either.

I have not had any problems until now. I’ve tried all the tricks - with itunes or no itunes, tried 3 different usb cables, different timing routines and nothing will work. I’ve tried on my desktop and my laptop with no luck.

I did get Seasonpass to dumps the blobs with the new beta but when I go to Jailbreak I get the “failed encountered a problem with possibly another program” that I get all the time now, so I don’t even try to use Seasonpass to dump blobs and then create a jailbreak with the beta because it never works anymore.

Then I even used iFaith to find and download the blobs I saved with Seasonpass earlier on the iFaith server and saved them. I then tried to use them to create a custom ipsw with snowbreeze but snowbreeze is giving me an error that the blobs aren’t good that Seasonpass dumped.  

Very Frustrated at this point!

So my question to you all is there something going on right now I’m not aware of that may be causing this globally for some of us, or is just not my damn day??

I’ve fiddle fuqed with this all day and I’m really getting pissed!!

Any suggetions??