Fresh JB (5.3), cannot SSH?

I’m having a heck of a time trying to get SSH to work on my aTV2. Seas0nPass seems to work but then aTV Flash can’t find my aTV, so I figured it must be an SSH problem. After jailbreaking, I logged in and changed the password out of habit, but now the connection times out when I try to login. I was able to login for about 5 minutes but now it just times out. I’ve restored and jailbroken this thing 4 times and keep getting the same issues.

About a month ago, Infuse stopped connecting to my mac, the remote app stopped showing my aTV and Hulu would give an error when trying to watch episodes that I’ve watched one or more times. I put up with it until yesterday and now am stuck. I don’t get any errors from Seas0nPass, though it takes some fitness to get it to “see” my aTV. The weird thing is that the Hulu and Remote App problems persist even though I’ve restored…

Here’s what I have tried thus far:

  • Used Seas0nPass
  • Used iREB and the custom f/w the SP created
  • For the Hulu problem I went as far as creating a new free trial account and logging in with that to try and get the app to delete some caches or something
  • Manual IP and DNS
  • Auto IP and DNS
  • Use terminal for SSH
  • Use transmit/cyberduck for SSH
  • Use ssh root@apple-tv.local
  • Use ssh root@192.168.1.xxx
  • Use ssh -v … but no useful info is given
  • Force reboot (Down + Menu)
  • Normal reboot
  • While the device is booting blast it with SSH attempts and also try opening remote app. Sometimes the remote app will see my aTV, but the SSH has not worked.

Netflix works fine, if that matters. I guess I could buy a cheap router on craigslist and see if it is my router… Though I’d rather not waste money on it. My router is a Linksys E4200 or E2400 I cannot recall at the moment. Or could this be a hardware thing? I’ve tried everything I can think of, I hope someone can point me in the right direction…