Frame skipping iOS/tvOS 14.5 beta

Hi, I noticed that Infuse on iOS 14.5 latest beta /Infuse latest beta has some serious frame skipping. Seems, strange, that it only affects the iPhone 12 Pro at the moment, iPad Pro is running the same 14.5 build, same Infuse and the same video file is playing perfectly fine…. Already reported to apple but help from Infuse team would be greatly appreciated too I suppose.

I think that this is an iOS issue, when I wanted to record the fault and started screen recording I couldn’t catch the problem. It just went away, as soon as I stopped the problem came back…. oh man….

1 Like

Do you see it with you eyes on every movie ?

I tried with 3 movies (WebDAV and 1080p for movies)
Same build, iPhone 12 Pro
But no similar result

Tested it on iPhone 11 pro with latest beta and IOS. 1080 bluray, 1080 web and 4K movies.
No issues

Is it only one file on your iPhone?
What happens if tou use a different video player?

It’s not that obvious, I spotted that same behavior while watching Netflix, it’s like the movie is playing fine, but for 1-2 seconds there is a sudden frame drop like from the usual 24p or 30p to 20 or 15p and goes back to normal. It doesn’t happen at the same moment, I guess it’s OS realted.
Had the same issues when the Xs came out and it wasn’t fixed by apple for a long 7 month period…. and not all ppl see this :frowning: like my wife, she wasn’t able to distinguish normal playback vs frame drop playback….

And like I said, only iPhone 12 Pro may be affected or at least the new chip, iPad Pro doesn’t have this….

For now I t’s a tvOS issue as well.

1 Like

Haven’t tried. Will test tomorrow and report back

I am seeing this issue in the latest beta, on non-beta tvOS. So it’s an issue in the app, not the OS. Seen the issue on 1080p/SDR content as well as 4K/HDR content.

CC @james

1 Like

Hi
Noticed over the past few days my videos juddering on the ATV, saw today it’d updated to 14.5 beta, thought it might be worth a mention.
ATV 14.5
Infuse 6.5.9
Using an optima 1080p projector

Thanks for the reports!

We now have this on our radar.

Hi, in the case of the iPhone and iOS 14.5 I think I pinpointed the problem. Seems that this issue happens when Autobrightness is turned on in the phones settings. I recall something similar happening I think on the iPhone XS, it has mostly to do with some iOS bugs. I will report my findings to Apple too

1 Like

Just noticed that when I turn of automatic brightness in the iPhone settings I don’t get the frame skipping anymore… will do more testing, already reported to apple too.

This issue (frame skipping) occurs in tvOS 14.5 beta 1 also. It’s unrelated to a brightness setting because in this beta Apple appears to be trying to fix the integer/frame rate mismatch i.e. 23.976/24 fps. Hopefully beta 2 will correct this.

How do you know this? Also strange because I don’t have that behavior when auto brightness is turned off. Either way it’s most likely related to iOS

I am in the dev program and there is a tvOS beta forum where almost all of the discussion is about this issue. I wasn’t aware that this was also a problem in iOS until I saw your post but it makes sense it would be for iOS and iPadOS in addition to tvOS. In any case I’m sure it will be addressed soon.

Thanks for the info, I hope ppl are reporting it. There was a similar problem with the Xs when it came out, iOS 12 and the new CPU, there were big issues with the frame drops on video playback, the problem hasn’t been fixed for several months. I was reporting the issue every niew iOS build…… I hope they’ll fixt that soon and not in several months….

tvOS 14.5 Beta 2 came out today, and It now FINALLY supports both integer and fractional refresh rates, including 23.976Hz and 24.000Hz. Seems like Infuse will need updated though, because of its custom video player, as it’s still outputting everything at 24.000Hz.

1 Like

Are you sure it’s not respecting the Match Frame Rate flag? I thought @James said it did.

We’ll be getting things tuned up for tvOS 14.5 and the new output options soon. :slight_smile:

23.976 FPS matching works on pre-14.5. It seems they changed some things and Infuse needs a few tweaks.

2 Likes

Yeah, it does, the “still” outputting part of my comment was specifically about tvOS 14.5 Beta 1. Stable releases of tvOS output 23.976fps content at 23.976Hz with Infuse.

Awesome, glad to hear it! One thing I thought was kinda odd I noticed too, is in the past infuse seemed to correctly pass through correct MaxCLL/MaxFALL HDR10 metadata on a per title basis, but when I was testing out 14.5 Beta 2 today, I noticed it seems to be passing through dummy values for those now. Could you take a look at that too, if you weren’t already aware?

1 Like