Forgoting TV Shows series

Each few days (week or so) Infuse (not only latest, but previos versions too) forgoting TV Shows series grouping. So, when I open TV Show folder, I see whole episodes and must wait for new grouping. This happend many months. Problem was on aTV 4K 2021 and 2022 (LAN version) too. Metadata delete not solve it. All TV Shows have data on NAS.

Is this while browsing your share or in the Library?

Can you provide a screen cap of the file structures for a whole TV show that is showing this problem?

What do you mean by

Do you mean you have nfo files for all shows or that all tv show files are on the NAS?

Sounds a little like when the ATV clears the metadata every now and then whilst its re-populating generally things aren’t where they are supposed to be until it completes, “I see whole episodes and must wait for new grouping”.

1 Like

It is while I open favorite (on screen cap - “02 Seriály”) placed on NAS folder from main Infuse screen, where for each I have subfolder (on screen cap - “Californication”). While re-populating, I waint until all files are grouped to seasons.

Have you tried putting all of season 1 episodes in a sub directory named “Season 01” and all of the season 2 episodes in a sub directory named “Season 02”?
TV Show Name and structure

1 Like

Why to do this? Before months was not problem.

Using standard series and season filename formats and folder grouping helps Infuse more quickly identify and group content correctly.

As to why you might be needing to do this repeatedly, and what you might be able to do about it … well, click those links.

Or follow the full discussion if you are up for some light reading:

1 Like

Thanks, I read something and … cant tell, what I mean about Firecore :slight_smile: But, what I can tell is, that I have only 2 apps on aTV, Infuse and Youtube. Disabled automatic updates, disabled automatic installation, have only personal 1 black photo scrrensaver. Infuse occupied 129MB, Youtube 66MB. I have 128GB version of aTV. Metadata occupied 1GB.

Assuming you aren’t downloading any content (movies / tv) to your AppleTV, and you did get rid of all the AppleTV screensavers (which might have downloaded in the background even if you are only displaying your one custom image) I can’t see any reason why your device would have filled up so much space as to cause your Infuse metadata to be erased. That would be quite odd.

If you can figure out what might have caused it (if indeed that is what happened to you), let us know.

Im always interested in these topics because im yet to figure out why my ATV clears the cache on Infuse, it does on my friends also and his library his very small compared to mine and mines not that giant compared to some of the guys on here.

It happens all at once for me, IE one Apple TV will do it and its cleared on the other also, I dont always notice it but if the one in my daughters play area clears then by the time I get into the lounge later that day or night or the day after it also has to re-download everything.

I should probably look into it but its not happened in a while and each time it re-caches I think ‘oh screw it’ its done now.

1 Like

I don’t think the OP is complaining about the Infuse data being cleared on the ATV, they state that their TV shows instead of showing seasons display individual episodes and then will regroup into seasons. I’ve seen this behavior when users don’t separate their season files into individual directories. The above recommended file structure helps eliminate this problem.

If they were having the problem of the ATV clearing the cache it’d show a total rebuild and not just the seasons changing to individual episodes.

1 Like

Yes I agree, we should always separate using folders, this isnt specific to Infuse as well, most people who move to Infuse from something of course much worse :stuck_out_tongue: are already in folders structures.

Im not sure its all that clear what the OP is describing, perhaps its less obvious when movies are populating because they are usually on their own anyway, its super obvious when TV shows are doing it because they get a long line of episodes before they snap back into a single thumbnail for the season. Ive only seen that happen when the library is starting again.

Looking closer at one of the statements he makes,

Maybe he has a favourite set rather than just navigating to the present TV Shows section and finding in in there. Do favourites behave differently?

I’m currently in a possibly unique situation to comment on this — as I no longer have home internet, and had not yet processed and imported some of my newly acquired series when the loss occurred.

My metadata has not crashed or been discarded by my AppleTV but I am unable to acquire new metadata without my AppleTV devices connected to both my NAS and the internet.

I’ve subsequently moved and renamed a large number of files which has similarly played havoc with Infuses’s database.

  • Items that have not been moved or renamed still appear as normal — with full metadata.
  • Moved items appear as normal assuming they have have local artwork images and local metadata (.nfo).
  • Renamed items with local images and metadata appear as normal but have incomplete textual metadata — as infuse only reads the .nfo of items already identified as TMDB titles during import to its library.

Consider this show: Humans (2015)

Humans entirely lacks local images and textual metadata and was never added to my Infuse library — I therefor access it through my “TV” favorite (i.e. using the folders view). Episodes are ordered into single-season subfolders and named appropriately for scraping by Infuse for identification via TMDB.

Here is how the folder appears (among other series’ folders, shown at varying stages of processing) in the “New Series” subfolder of my favorited “TV” folder:

Here’s how the Humans (2015) folder looks — note the unexpected differences compared to a series that has been indexed. This folder should list three Season # subfolders, as that is the folder structure. But it doesn’t.

And that’s because Infuse doesn’t work that way. In cases where there are no video files in any given folder, that folder is skipped entirely and instead shows all the video contents of all subfolders of the skipped folder as if they were the direct contents of the skipped folder. (This results in all three of HumansSeason # subfolders being skipped by Injuries, and all series episodes, from all three seasons, being displayed together — as I believe was described by the OP).

Only after these items are scraped and indexed will Infuse’s file browser finally show the three Humans season # folders, and have “moved” all individual episodes into their (now visible) appropriate season folders.

It doesn’t matter if the new items never need be added to the library — Infuse’s folders view requires all contents to be indexed regardless, before it will show them appropriately in the Season # subfolders that actually are in.

Lastly, this is what the TV episode details page looks like for the unindexed Humans series:

I’ve noticed this behavior even when my files are separated into folders. My copy of Survivor, for example, has hundreds of episodes spread over 44 season folders (Season 01 thru Season 44). But if the metadata is erased (because my AppleTV flushed it — or I did, by manually toggling off/on the folder setting to “Use Online Metadata” to force the folder to refresh, because I had renamed files or updated the series’ artwork) the main Survivor folder immediately reverts to one with zero Season # folders and hundreds of unindexed episodes.

As you watch the episodes become indexed, you see them get updated (horizontal) thumbnails and be moved into the newly acknowledged Season # folders you’d set up previously.

(The Library version of the Survivor series simply disappears when the metadata is flushed, and only reappears when individual episodes are re-indexed and re-added to the library. They’ll be moved almost directly into their proper Season # subfolders.)

Still not fixed :frowning: I tryed move one TV show to folders (each season one folder) and same problem, after time (or tvOS update), partialy or full cache is gone and I must open each TV show for renew season groups :frowning:

Is this happening when you browse in the Library or when you browse in the share?

What type of connection are you using to connect to this share in Infuse?

If using something like UPnP or DLNA, these servers may reorganize files on the server from time to time (usually when files are added or removed) and in cases like this Infuse would recognize these as new files and would need to regroup them.

I have Synology NAS (723+), connected with SMB3 and using only shares, I don’t use library.

New updade, still not fixed. Separating seasons to directories is no solution, same problem. Maybe is problem because of files count? I have over 7800 files in TV series directory. But, few TV series have in other directory and other favorite and it is same problem.

After last update it seems, that this is solved. I try to clear cache, open each TV series, each season, so, all was updated (near all). Now I have 1.1GB cache, 8500 files in TV series (other TV series are in other folder). I restarted Apple TV, make update of tvOS and still OK. Hope, that this will not go back :slight_smile: