Forced subtitles in ISO

Love infuse but having an issue with subtitles.

With some movies, I can select the track for forced subtitles and other movies there is no track available. I therefore have to select the English track when the characters are speaking a foreign or alien language and then deselect this track when they speak my language (English). I am using ISO files so all tracks should be included yet often the forced tracks are not in the subtitle menu. Is this an Infuse quirk that is being planned for a fix or something I am possibly incorrectly doing when creating an ISO?

  • when I play the physical dvd in the player then the forced sub tracks play as expected.

Are there particular DVD titles you are seeing this with? Normally a subtitle track will be flagged as ‘forced’ and Infuse will always display that, even if the main subtitles tag is disabled.

However, it’s possible DVDs handle subtitles a bit differently and we may need to look into it a bit more. We have a number of subtitle related improvements planned for Infuse 5.4, so it might be a good time to look into this as well.

Hi James

I am working through all my forced subtitle ISO files at the moment (there are just over 90) and quite a few of them are displaying this behaviour. A couple of examples of different subtitle behaviours are:

Behaviour #1: Dances with Wolves & The Revenant - both have a track that only shows the subtitles for foreign language. I found the track via trial an error testing each English track in the subtitle menu as they did not ‘auto select’ when loading the movie. I found I had to select the track each time I entered the movie to watch as Infuse did not remember my subtitle selection - maybe this can be implemented as an iCloud remembered setting?

Behaviour #2: Angels & Demons and 2012 - both these movies have subtitles but they are for the entire film (even English parts). They are tracks 5,6 & 7 on 2012 - there are no tracks 1-4 and track 4 & 5 for Angels & Demons - there are no tracks 1-3. I am technically ignorant so don’t know if the lack of tracks 1-4 / 1-3 indicates anything? They are complete ISO copies made with a purchased application and I did a full copy rather than selecting the main feature option. (I won’t name the application but they are done on a Mac and are from DVDs and it Rips like a Pro, if you get my drift)

I re-tested the physical dvd’s in my player and they worked fine with no input from me. I also noticed there are many discussions on these issues on discussion boards for the other applications that are similar to Infuse (but nowhere near as good ?) These boards actually discuss Angels & Demons quite a bit.

Let me know if you need more examples- I should be done with my testing in about a week so will then have a large spreadsheet of examples.

Thanks. We’ll see if we can track down a copy of one of these for testing. Most likely a fix for one will cover other similar cases.

Thanks James, :wink:

just finished testing all my ISO and 40 out of 96 are missing this Forced subtitle track in Infuse but they work on other similar APPs


Hi, wondering how you are going with resolving this issue? Thanks!

Any update on this issue - the latest update that includes subtitle fixes has still not resolved it. Thanks!

It’s still on our radar, but didn’t make it into 5.4.1. Sorry.

Hi, A year on and no resolution yet?