For those who have already updgraded to AppleTV 4.4. Seas0npass is still working

For those who have already updgraded to AppleTV 4.4. Seas0npass is still working, it just downgrades to 4.3. I did it just now Oct 16 2011 12:54pm Australia EST. It did take me ages as I kept getting error 1600, 20 etc. When I eventually got it working I had put it into DFU mode before running seas0npass. Only had USB cable plugged in and did it by pressing down + menu until it does a fast flash, then pressing menu + play/pause till it does a fast flash. Then run seas0npass and follow directions.
Firecore Support Team make this in your Support List .you dont need (unless u have saved your Shsh blobs)

It partially worked for me. I got no errors and it did reset back to 4.3 but Seas0npass doesn’t jailbreak it. It’s just the regular legit 4.3 no Manage Extras menu

same here, i either get a stock 4.3 or error 21 / 16xx


been at this for hours now…

How did you check if the Jailbreak had worked?   There is no visible sign initially as no changes to the menus are made by the jailbreak?   The ways to check are one of:

  • See if a SSH connection works

  • See if installing the FireCore software works.  This Adds the Maintenance menu.

Either indicates a successful jailbreak.

Of course. Had a complete brain fade. Forgot Seas0npass no longer displays. So naturally main way to tell is to install Firecore app.

Don`t use the nwest ver. of iTunes. works fine for me

If iTunes doesn’t give you any errors then the jb has worked. The season pass logo doesn’t show in this version. Just proceed to run at flash black from your computer.

But, if it downgrades to 4.3, I think it will not be able to enjoy the iOS5 mirroring functionality. Right?


If that matters to you then you will have to do without the Jailbreak (and thus the ability to install extra software) until SeasonPass is updated to handle the iOS5 jailbreak.


As I imagined, let’s hope that SeasonPass will be updated soon…