Followed instructions, got "success" message but stuck on connect-to-iTunes screen

Hi, I've gone through the forum but most of the topics relate to the previous tethered jailbreak...

So here's what I did.

I got the latest SeasOnPass, ran the "create IPSW"

Then successfully got the appleTV to go into DFU mode. All the processes ran. (No power cable!)

Finally it said the jailbreak was successful. And no more options.

So I unplugged it, plugged it into the HDMI and power.

But it stays stuck on that "connect ot iTunes" image (giant usb cable and iTunes icon)

I tried rebooting it by holding the menu/play button.  Tried rebooting with menu/down button... nothing.

(This was the same process as I saw on youtube and on the jailbreaking 101 thread)

So I then tried running the process again. But same results.

I read on one of the threads that I should try to plug it into iTunes and revert it to factory settings so that I can try the whole thing again. But after the entire download process I get an error.

Is this the end of my little black box???? Please any advice will be awesome. What did I do wrong?

Thanks in advance

first was the apple tv working before you started the process? if it was try another micro usb to restore it back to factory in itunes. if it doesn't work borrow someone computer(pc preferred) and try to restore it if you get the error(error 9) forget about it the apple tv is done. if a 1600 error try anther usb slot with a better cable

Seas0npass bricked my ATV2 as well today. Sucks. (Error 9)

I have been jailbreaking it for years.

 

UPDATE.. NOT BRICKED AFTER ALL! After trying a different usb cable, and under parallels, with the power cable, and all the other methods people have posted, I thought about changing USB ports to one of the ones off the Thunderbolt monitor... and it worked. So there you go.. 

Hi Enigma! Wow sounds hopeful! Ok I'm still positive. I'll give it a couple of goes tonight! let's hold thumbs :D

OK. Success!!!!!

Thanks Enigma!

So here's what I did:

I unplugged everything. Wacom tablet, phone cables (even though nothing's connected) all USB cable. Then plugged the Micro-USB into the back of the machine

Restarted. Then plugged in the ATV and did the restore.

It worked. Then I ran the jailbreak again. And this time it worked.

Whoohoooo!!!!!