Folders start loading thumbnails then program crashes

Running the latest version on the new apple tv connected via LAN cable to airport extreme with USB HDD. When I open my movies folder I see the folders appear and the thumbnail images on the folders start populating. It gets through about 20-30 of them then they stop loading. When trying to play any file after that point I get “An error occurred loading this content.”
I tried clearing all the metadata and it didn’t work. So at this point I am stuck, I can’t play any movies.
What does work is if I close the whole program and then open again, wait for it to connect then quickly scroll to a movie and play before the metadata loading crashes everything.

Try Uninstalling Infuse , and reinstalling .

Tried reinstalling, didn’t work. Same issue

I am having the same issue. When I click on one of my favourites folders, it gives me the “An error occurred loading this content.”
Sometimes, if I choose another favorites folder, it loads ok, then switching to the other folder ends up working as well. Strange.