Folder picture is blank

Hi there. Some of my folders with TV-shows content are blank. Some of them are not. Example:

Billions has cover photo but Superstore does not.

I have looked for solutions online but I can’t find them so I turn to you. Is there any way to add either my own pictures to each folder or let Infuse do it for me?

I am using NAS Synology and Apple TV.
Currently I have a picture saved as Superstore.jpg in the size 1000 x 1498 inside the Superstore folder where all the subfolders with seasons are.

Welcome to the forum!

Often these issues are due to either the TV show folder naming or the organization of the seasons and episode files. Could you do a screen cap of the file organization for the Superstore files?

Also it often helps to have the seasons in their own folders inside the TV show folder.

Here’s an example for the TV show “Deadwood”

If you wish to provide your own artwork instead of letting Infuse getting it from TMDB you can see the users guide for this here.

I don’t know how to create a picture like the one you showed here.

It is not only Superstore there is an issue with. It’s like 95 % of all the folders. But some are appearently fine.

Here is how my Superstore folders are set up:

  • I have a folder for all TV shows.
  • Inside that folder there are many different folders, one for each tv show, one of them is called Superstore.
  • Inside that folder there are two folders and a picture. One of the folders is called Season 01. The other is called Season 02. The picture is called Superstore.jpg.
  • Inside the Season 01 folder there are 11 video files, one for each episode.

I have read through the link you’ve given me but I do not think it helps. But maybe it is because I do not understand it.

Okay, let’s see if this helps. Organize your files and name them like this
Superstore File Structure and names

This should let Infuse fetch the artwork for the TV show folder after you open it in Infuse.

Now if you want to provide the TV show poster place the artwork in the TV show folder and name it “poster.jpg” like this
Superstore with poster
If “poster.jpg” doesn’t work try “folder.jpg”

Also, how are you connected to your NAS? Are you using SMB, FTP, DLNA, UPnP, etc?

I changed the names of each episodes to the example you gave me above.

That worked!

Will this create issues with the automatically generated subtitles? Normally I do not change the file names because I have been taught that this will make it easier for Infuse to find subtitles for me.

The movies are stored on my NAS Synology. I use an Apple TV connected to a TV. The Apple TV has Infuse installed. It is all on wireless internet.

What protocol are you using to connect to the NAS?

You should have no problems with Infuse gathering subtitles using the correct naming function.

Okay thank you very, very much!. It looks much better now.

I have one final question before I leave you, if you will, but it is a different topic. Do you want me to start a new thread with the new topic header? Here is the question:

Is there any way to get out of “Use local metadata” once you have accepted? As I was trying to solve the pictures on folders issue I had, I tried many different things. One of them was to test it on a folder what happened if I used local metadata. This was before I started this thread. The folder I tested on was Billions and after I wrote the initial question, the folder started to change a bit. Now it no longer calls itself Billions but calls itself 62852. My Billions set up is exactly like my Superstore set up now with folders for each season and the naming.

Also the order of the seasons are weird. In my NAS Synology they are in season order 01 first, then 02, then 03. But on my TV, season 02 is first. And the episodes are not hidden inside folders with season names but all in the same folder. This was not the case before I clicked accept to metadata.

Just long press on the item you set “Use Local Metadata” and select “Use Online Metadata".

1 Like

Please answer this question so I may have a better chance of answering you correctly.

And @remotevisitor gave you the answer to your other question. :wink:

For some reason that is not an option to me.

I have tried three different places.

  1. I have a favorite folder called TV Shows. When I long press on that folder with my Apple TV remove I get the following options:
    Rename Favorites
    Select Artwork
    Use Local Metadata
    Hide Favorite
    Remove Favorite
    Cancel

  2. Inside that folder there is another folder called Billions (Except it is not called Billions anymore. Now it is called 62852) When I long press on that folder with my Apple TV remove I get the following options:
    Playlists
    Cancel

  3. Inside that folder there are all the episodes from the TV show called Billions. On my NAS when I am connected to the PC, they are divided into folders of seasons but on my Apple TV using Infuse they are all together in one large Netflix-looking overview. The first episodes shows are s02e01. After all the episodes from season 02, I get all from season 03. After that, all from season 01. After that, all from season 04. They are all in order except season 01 is mixed up somehow. When I long press on the first episode with my Apple TV remove I get the following options:
    Mark as Watched
    Edit Metadata
    Playlists
    Cancel

Can you help me?

I have looked up (on Wikipedia) what your questions mean but I actually don’t have an answer for you. I don’t think I am smart enough to understand.

I want to thank you for all your time and the effort you have put into answering my newbish questions.

And once again, could you please say what protocol you are using to connect to your NAS? It will be either SMB, FTP, UPnP, DLNA, or one of a few others.

Ok, in Infuse on the Apple TV, go to Settings (the gear in the upper right corner of the home screen)

Then select Shares (under the network heading)

Then under SAVED SHARES click on the one that you are getting your files from.

Then select “Edit Share” (below the list of favorites)

The first line will be the Name and then the second line will be Protocol.

What does it say on the Protocol?

I followed your guide but I didn’t get to the end before it told me it was SMB.

I clicked on settings, then selected shares. Then it said SMB.

As I was fiddling with this I suddenly realized we might not be talking about the exact same thing.

I have always used a favorite folder called TV Shows for my TV shows. But today I noticed there was another folder also called TV Shows (Pink icon of an old TV with antenna). When I open that folder (on my TV) I can actually see everything is as it should be. All shows in alphabetical order with pictures on the folders. The subfolders (seasons) also have pictures.

Now the only problem I have is that I cannot get Billions to show up in there. I believed I screwed up when I decided to activate the metadata option. Can you help me?