"Flashing / flickering" subtitles - Synology DS118 - ATV 4K - Infuse Pro // Empty Music-folder

Hi everyone!

I installed my first NAS last weekend (using Synology DS118 with ATV 4K and Infuse Pro - Stream: WiFi / SMB) and I have two minor problems:

  1. while streaming videos (TV Shows / Movies) with & without forced subs, the subtitles “flicker / flash” for a milisecond and then disappear again… This happens with every video - although I switched “Subtitles” to “OFF” in both Infuse AND ATV… The only way to stop them is to swipe down while the movie is running and turn off the subs again… Wouldn’t be an issue, but some movies require the forced subs (e.g. Avatar or any movie with Russian dialogues :wink: ) - and when I generally switch them off, not even the “necessary forced” subs appear…and when I leave them on, the flashing/flickering starts again… Picture and Sound are both absolutely fine… Any idea about this!?

  2. when I open the folder “Music”, Infuse says “This folder is empty…” - although it is filled with hundreds of mp3s… Openig the folder with my iPad (using the Synology Music App), I can see all the files, but still can’t play them… ?? Files are all named “Artist - Title.mp3” - playback via USB-device or iPhone works fine…

Thanks in advance for any help / ideas!



No idea about 1), but regarding 2) at this point in time inFuse is purely a video player and does not play free-standing music files. The audio formats supported only apply when they are embedded in a video file.

There have been frequent requests for support of free-standing music files, but whether this will ever happen I have no idea.

Ok, thanks so far - the music isn’t that important anyway…I just noticed it… :slight_smile:

Do the subtitles flash when you play from sources other than your new NAS? You might want to try a test share on a local computer and see if it’s the same.

I also have/had a Fantec 3DFHDL and a LaCie LaCinema HD in use - they‘re both directly connected to the TV/AVR and the subs are perfectly fine…also when I check the files on my computer (Win10 / VLC) everything is as it should be…so it is either an issue with the Synology or with ATV/Infuse…

My question again was does the flashing occur when you used Infuse on the ATV with the share on something other than the new NAS?

Sorry, didn’t get that right… :wink: I’ll check it later - but the only other source I could use is the PC…

Were you using Infuse prior to the new NAS? If so was it not flashing with where ever you were connected to for shares? If it’s all new including a new install of Infuse along with NAS then you also may want to try deleting Infuse and doing a clean install. I know it’s a hassle but this is the first time I’ve ever heard of the subtitles flashing so maybe the Infuse install got a byte garbled.

Just a wild guess. :wink:

No, it was the first time ever - I bought my ATV 4K just 2 weeks ago… Before that I always used Media-Drives (like the LaCie or Fantec) directly connected to the AVR, but I was tired of always switching between different devices… Now I have the ATV and can watch Amazon Prime, Netflix, iTunes and all my files from the NAS with only one remote/device :wink:

So the installation was absolutely “clean” - but I could try to reinstall it…but first I’ll try sharing via NFS…let’s see, what happens… :wink:

One other thing to try before you change to nfs is to try the other options in Infuse for SMB, there was a recent rewrite to allow for the newer standards but there is also a legacy setting that many folks find to work best for their particular set up. Give them a shot first before the other more involved tests.

Tried to use NFS now, but didn’t work → “Indexing failed”…anyway…renewed the SMB-settings (enabled all SMB modes (1, 2, Large MTU, 3)) and tried several files:

“Forced subs” in TV shows (NCIS, TBBT) work - even with generally switched off subs (which is fine for me)… But “necessary forced subs” (as in Avatar, Na’vi speaking) are still flashing, when switched ON (visible for miliseconds, then disappear) - but with both Infuse/ATV “Subtitles switched OFF” they are “OFF” - no need to swipe down and switch off again… Well…I think I’ll have to learn Na’vi and Russian now… :wink:

Thanks again for your help - even if it’s not really fixed… :slight_smile:

Welcome to the forum!

Can you provide a bit more info about the videos you are playing when you are seeing this flickering issue? Are these DVD/Blu-ray videos with the original embedded subtitles, or external subtitles like SRT/SSA?

Is it affecting all your videos, or just Avatar?

BD/DVD rips with original embedded subs (which can be switched on/off) - .mkv, .ts, .avi… Subs flicker with all movie-files when switched ON - when switched OFF, everything‘s fine, but then you have no subs at all, which is not helpful when dialogues are in other languages than English or German…

Little update…:

Reconfigured my setup a little and bought a new AVR yesterday (went back to ONKYO, after the Marantz didn’t support Dolby Vision and I always had the feeling, the real “punch” was missing - checked it with Iron Man 1 (starting sequence / escape from the villain camp)…yep…punch’s back… :wink: )…and ATV also changed to DV automatically…

After that I started a new NFS share (realized that I entered the NAS-IP as “Client” in the first try - no wonder, “Indexing failed”… O:-) :smiley: ) and with all folders updated (took quite a while - can’t say NFS is THAT faster than SMB…)…S H O C K…: could find all covers / metadata / files, but no matter which I selected, nothing happened…just black screen… shok

Ok…back to work…deleted the NFS share, started a new SMB, waited for folders to be indexed, selected a file…still black screen… confused aggressive Thank god my wife is in Milan - wasn’t a relaxed evening… ;-p

Last try: deleted the Infuse App, re-installed it, started a new SMB share, waited again…and tadaaa…finally… :smiley:

BUT: some subtitles still flicker…especially Avatar…no idea, why - but others (like all “handmade” subs for the US Shows (NCIS, TBBT) work…so it must be an issue with the file itself… Anyway - I don’t give a shhh…eep… :wink: - I won’t change a running system again…

One last thing - maybe someone has an idea about that: sometimes the ATV doesn’t wake up when I press a button on the remote or start the iPhone App…only chance is to unplug power…which is quite annoying… confused I know it’s not a Firecore issue and I’ll also address it directly to Apple, but maybe someone has the same problem…


I just wanted to start a new topic with Subtitle problem like yours, then I saw this post. I have encountered these two problems, flickering/distorted subtitles on Apple TV 4k, and not being able to wake up Apple TV with remote. First: Can you tell me which TV you are watching content on? I have new LG OLED C8 and yesterday discovered the cause of the flickering subs: LG’s TruMotion. If I disable it (on OFF), subs are perfect, but if I turn Trumotion ON (no matter which setting) subs are flickering from time to ime, not always but mostly in a motion scene. It’s not too much of problem, but it is noticable enough. Second: In last two weeks it happended two times that I can’t wake up Apple TV 4k with a remote. No light on the box, like it’s dead. Only thing that helps is disconnecting the power cord. Maybe it is remote related, so I programmed the AVR remote to work with ATV and now I’m waiting for it to happen again so I can try.

My TV is an LG 65E7V, but TruMotion is always OFF, so in my case this is not the reason for the problem…

So, same as me, LG. Well, this is interesting because I never heard of that problem with other brands of TV. It has to be something with how LG motion processing is handling Apple’s subtitle layer on top of the content. Try disabling other picture procesing options until subs are perfect.