Flash Player-Boxee Beta issues

I have read a number of comments on this issue and was wondering if anybody has anything to add after reading this? I have always maintained updates and have also updated with every version released and it has worked perfectly. I recently updated to 4.1 and everything was ok, I updated to Boxee beta and it was working ok just some issues with meta data, I was able to watch streaming TV and Flash player was working. I read in this forum on recommendations that having boxee alpha and updating to beta there may be some issues so it would be better with a fresh install, so I reset the ATV to factory default. I then updated to the latest Apple software then installed to the latest aTVFlash, I followed all procedures as set out in aTVFlash instructions and the first thing I noticed that there is no startup sound when starting the ATV. After this I installed Boxee beta and now I cannot watch streaming TV anymore, or flash player on Firefox. I have read the forums on this and have read your fix for this installing flash with CoreAudioKit.framework. This would be fine if I could find it. I am using a Snow Leopard Macbook. I have tried for 4 days to find this even to the point of trying to purchase it but it is so outdated I cannot manage to do that either. Now putting all that aside, how is it that this was working using Boxee beta when I first updated this, I had even watched a number of TV shows on Boxee beta on both Hulu and CBS. I have never put in any frameworks previously or any additional software other than the products supplied by aTVFlash? Also the startup sound was working after my first installation of 4.1 as well, like I said the only reason I did the fresh installation as I read of some issues in this forum suggesting this. Now I regret that I did this at all. I have spent the last four days trying to get this working to how it was to no avail. I would like to know if others had a similar experience, even better if they could help me to fix this? Thanks and regards in advance.

The startup sound missing on aTVflash 4.1 is a known bug.

Check your mail…

Thanks for your input “odimb”, the details in your email worked a treat. Now still my question to maybe aTVFlash staff is why did both the startup sound and Flash Player work after my original update to 4.1, but only after I updated after a factory restore I had these issues. Also an additional problem I just encounted is that now Sapphire is unstable, I have never encounted this previously.
Anyway I am happy now and again most appreciated.

I am having EXACTLY the same issues almost word for word. No sound at startup (can live with that as long as everything else works) and worse, no feeds playing in Boxee… Is there anyway I could get that magical email forwarded to dystonic01@gmail.com ? Please? Thank you in advance!!

Thanks! Gonna go install now…

Crap. Still not working for me. Firefox now crashes upon opening. Still no apps playing in boxee. I tried boxee beta and nothing. Everything else seems to work fine. Except for boxee which is what I used the most. This sucks! I wish I had never updated. Is there something I am missing? Thanks.

Did you follow the guide?


i cannot watch any video from boxee and the sound does not work at start up which i can live with. I also can not watch video on my web browser. i have a mac running snow leopard, can anyone help ? Thanks

Dystonic01, did you get it working ok after following the guide from adinb? This is a very concise guide and I believe if followed should work. All I can add if it doesn’t all I can say is that try the factory restore, but before you do save the MacOSXUpdCombo10.4.9Intel.dmg as well you need the CoreAudioKit.framework. The reason to save the MacOSXUpdCombo10.4.9Intel.dmg is that after you install the latest ATVFlash and run the smart installer it will require to download this again, just saves you waiting for a large download. So you have done the factory restore now update the latest ATVFlash, now copy both the MacOSXUpdCombo and CoreAudioKit files that you saved to the documents folder that has been mentioned in the guides you have probably already read. Now run the smart installer after it has completed reboot your ATV. After you have restarted now install Firefox followed by flash player, just check the CoreAudioKit file is still in the documents folder before you install flash player, after you have installed it you should see that the file has now disappeared, this means that it should have installed correctly, also install flash from the maintenance option not from Nitro, not sure if it makes a difference but that’s how I did it. Finally install Boxee Beta. After this is all done reboot, all should be working now. This is how it worked for me after a fresh install and the reason of the sequence I did it in was based only on logic that Boxee requires Firefox to work so I thought that should be installed before Boxee and installing flash player may be more more beneficial to be installed after Firefox, now this could be just dumb luck it worked this way for me but thought I would share my experience.
And I would only do all this if you have no success with other guides from more experienced people, I know nobody wants to go through the pain of starting over again.
As for another question in this forum about Firefox crashing and not playing video I did have that before I went through my above steps. Although I can play video through Firefox it is not great a bit jumpy and I can’t manage to go to full screen very well because I can’t seem to get the aspect ratio right in firefox on a wide screen tv, so it is distorted on full screen. Also remember unless the video you are trying to play in Firefox unless it requires flash it probably won’t work.
Anyway all works for me, just still no sound at statup, I figure eventually one of the updates will fix this, no biggy for me.
I will add I haven’t updated the latest 2 ATVFlash updates 4.1.1 and 4.1.2 my last update was 4.1 but I have run the updates internally from the maintenance option and still working ok, I will wait for a more comprehensive update.
Good Luck Guys.

I did not. YET. I have been so damn frustrated with this thing that I have been ignoring it unless I want to watch a movie. I have just been using my tv as a second display for my imac and watching hulu on there… I am going to try this out tonight. Thanks!

No dice. This is lame.

The only thing that I saw was missing from the directions and my set up is number 6, the second part. That does not exist in my browser settings so it cannot be enabled. Am I missing something else as well then? It doesn’t seem like I do as every damn person who updated cannot use hulu or any other video app in boxee. What sucks is that we all paid for this.

Now I just wasted more time for nothing. No hulu. Same S#!+…

 I am having exactly the same issue. Complete fresh install of ATV then installed Boxee, now ATV locks when trying to exit Boxee or resets automatically when going in. Sapphire also crashed when I tried to update the scraper. These two add ons are what attracted me to ATV Flash and neither work. I have to say this is not acceptable considering that I have been charged for the initial software plus an update charge.

Please no moderator messages pointing to the link on CoreAudioKit.framework, it is not OK to expect customers to become IT experts and go round the houses to get a piece of software that they have paid for to work in a stable fashion.

I expect ATV Flash engineers to resolve this problem and fast, the software cannot do what it claims in the adverts.

Save your breath (or fingers.)  They have't done anything at all about this for 6 months plus if not longer.  They did not give a sh!@ about their customers then and now they are fixated on the 2g Apple TV.  

I believe their "fix" is to just remove the adds that Boxee works with the Apple Tv.  Maybe I am wrong, but I don't see that as part of their enticing people in anymore.  I already had a network player and being able to use Boxee and more importantly Hulu (I don't have cable or regular stations coming in but still enjoy a couple shows) was the main reason I PURCHASED (WITH THE LIFETIME OF UPDATES) this constantly failing hack.  I now have to resort back to mirroring my computer screen to my television and watching Hulu that way.  I wrote asking for a fix numerous times and they sent me links, (the fantastic do absolutely nothing but waste your time Core AudioKit.framework one as well)  which I used, to no avail.  I check in randomly to see if there is a fix and all I find is one more pissed of "customer" with the same damn problem.

 I believe it just boils down to the fact that they CANNOT fix it, are pretentious and stubborn not allowing them to post that they have FAILED and Hulu has won.  Again.   Meanwhile they will just blatantly ignore you or send you in another endless circle of unfixable failure.   They won't even supply you with an older version that did exactly what you wanted.  Like I stated earlier, they are fixated on the new ATV now so all of us that still have and use the 1st gen will probably just get ignored now.  It's already been their way of dealing with this matter...