Flash on Apple TV

This message is due to the lack of support you get to have flash working on aTV flash. I have been trying to get flash working now for quite some time and looks like many others have too. I have sent numerous emails to support who keep sending the same s%@&, back ( get coreaudioframework). Even if you do get it, it still wont work.

Then I have been reading countless forum subjects from people trying to get flash working and the reply they get from aTV flash support is ‘even if you do get flash working it is not that great due to apple tv proccessing ability’. I dont remember reading anything where the person was asking support what they thought of the performance of apple tv and flash. THEY LIKE ME WANT IT WORKING… IT WORKS BEFORE YOU INSTALL ATV FLASH AND WORKS QUITE WELL.

You pay $50 for this software that has so many bugs in it it would make a hospital cringe. I restored my apple tv to factory and installed the FREE atv usb creator and installed boxee and xbmc, which is the bulk of the software needed to play all your files and LOW AND BEHOLD, FLASH WORKS!!! JUSTIN TV PLUGIN (that requires flash) WORKS.

It seems i have paid $50 for something I could have just got free. It is obvious, something in the build of aTV Flash is screwing with flash as it should already be working!!! So TECH SUPPORT, WHY DON’T YOU START LOOKING AT FIXING THAT ISSUE IN THE NEXT BUILD INSTEAD OF TELLING US WHAT YOU THINK ABOUT FLASH!!! IT SHOULD BE WORKING!!! :cry:

I found this solution to work for me:

  1. Go to http://www.atvflash.com/maint/Flash100452.tgz and download the Flash Plugin File (note, this is the same website that the ATV uses to download when the install fails).
  2. Copy the Flash100452.tgz file to the ATV folder called Internet Plug-Ins.
  3. Reboot the ATV.
    After doing these I am now able to view flash videos from Hulu on Boxee. I had previously also copied the CoreAudioKit.framework as many other postings suggested so that may or may not be part of the fix. Also note, the ATV Flash install/update under Install Extras will not reflect the as installed or updated and it still will not updated, but flash is working anyway.
    Good luck!

I gave up on it a while back.
If it is as easy as copying to the plugins folder, how come ATV doesn’t just do this automatically? You sort of expect these little details when you buy it.

You nailed it, Chapco. I keep wondering what on earth is keeping the aTV Flash folks from writing a script to do this for their users, after all, the point of buying this is to enable this functionality in an easy manner, but its not doing that, and why should I spend money to get back to the same place I am now?

The Adobe Flash install option (available through the Install Extras menu) will download the current version of Adobe Flash and install it in the proper location. It will also relocate the CoreAudioKit.framework (required for Adobe Flash) to its proper home as well. Unfortunately locating the proper CoreAudiokit.framework is the largest hurdle for enabling Adobe Flash in Firefox and Boxee.

Guardian,

I appreciate your response to my question, however you still have missed the obvious question as to why does flash work properly BEFORE you install aTV Flash. You can install the free atvusb loader and install boxee and xbmc, which does give you most of the features you need, AND FLASH WORKS ON BOXEE… however since we have all payed good money for aTV flash, I WOULD PREFER TO USE IT… Something in the aTV flash build has screwed the flash component and it needs to be fixed properly. There was no need to install Coreaudio on atvusb loader. What now???

I remember at one point Boxee was distributing the CoreAudioKit.framework along with their software. While this would get Flash videos working, including this framework is a big no-no. Not sure if they still do it this way.

I keep getting a “permission denied” error for /Library/Internet Plug-Ins, (and I’m not allowed to change the 755 permissions of that directory). I’m using Cyberduck in sftp mode. Any ideas?

I really had this problem for quite a long time, but now it works great.

http://forum.atvflash.com/viewtopic.php?f=6&t=2629

open upper link and read the reply on page 2 posted by odinb

follow those instructions and the flash will work.

my aTV is 3.0.2, and aTVflash is 4.1.3.

thanks odinb!

I found out the hard way what Big E wrote - First, I made a copy of the core audio framework from the apple TV system library itself (10.4.9) and put it in the documents folder as they all talk about then actually took the most recent adobe flash (10.1) from my computer and put it in the internet plug-ins folder on the apple tv and it worked. Sounds like his way is easier but at least you can keep the adobe flash updated beyond the 10.0.45 that ATV program seems to install. Good luck all.

Hi can anyone provide a link to the Flash100452.tgz file and the associated link to http://www.atvflash.com/maint/Flash100452.tgz doesn’t work.

Also when I SSH the Apple TV I cannot find the Internet Plug-In folder - can anyone point me in its direction?

All I want is for flash to work, I have followed all of the previous threads using the CoreAudioFram,ework and other Apple files with no luck. Multiple resets of the ATV too but useless - any further help from anyone would be appreciated.

Cheers
DP

There is no need to install the Flash plugin manually…this is easily done through the Maintenance --> Install extras menu.

If Adobe Flash is still not working after following the steps in the guide below it is most likely due to an incompatible version of CoreAudiokit.framework. The AppleTV will require an Intel version from Mac OSX 10.4.10.

http://wiki.atvflash.com/index.php?title=Enable_Flash

If anyone is still trying to get flash working in Boxee, xbmc and Firefox, please see this link to get it working:

 

http://forum.firecore.com/topic/3040

Cheers,

 

I cant get Adobe Flash working, the whole reason I bought this! CRAP

I have everything up and running and the Adobe Flash 10.1.53.64 is working on some sites with FireFox.  My problem is the fact that Adobe Flash version 11 has been on the streets for a while and the “Install Extras” page on the AppleTV is not showing that an update is available.  Firecore is multiple revisions behind with Adobe Flash and because of this I am unable to view Flash vidoe on MANY of the sites I use due to the requirement of Adobe Flash 10.2 or LATER.  This feature is the main reason why I bought this product and I am not getting what I though I had paid for.  The website made it seem like updates would be readily available soon after released and that I would be able to keep everything current.  This is not the case.

If anyone has a way to update the Adobe Flash to a more current revision (10.2 or LATER) please post how you did it.  The Flash Player.plugin folder and flashplayer.xpt file are locked down and does not allow me to delete, rename, overwrite , or do anything without cracking the permissions.  All of the procedures I have seen so far do not work due to the permission restrictions on my AppleTV.