Flaky atv2. Restore or wait?

Hey all,

 

I have a JB’d ATV2 running 5.0.2. I recently updated XBMC to Frodo, and also updated my ATV flash black so I could get Infuse over Media Player. Since then, and over the last few months, I’ve had some weirdness. Such as:

  • not all posters appearing for Infuse - typically new files I’ve added just show up as a big ticket icon… this has never happened before. Reloading metadata does nothing.

  • XMBC has crashed a few times, the icon has vanished and reappeared, I can’t install repositories, and some of my installed add-ons have gone flaky

  • When I try to remove items using Maintenance, I can’t (such as couch surfer, last fm, etc). It says ‘removal failed’ after a few seconds, then if I try again, same result. Nothing appears on the log window.

  • My movie drive vanished off my Infuse, and when I went to re-add it, I had to use a different format (originally was AFP, but then I had to add it as SMB the second time to get it working)

 - When I go into the manage backups section, I tried to backup settings… failed. I checked the ‘backup firmware’ and have a few listed items here, going up to 5.1 (currently I’m on 5.0.2)

 

Which brings me to this: I was thinking if 5.1 is listed, maybe i should just use RedSnow and upgrade to this saved signature… My preference would be to update to the latest a version of the ATV2 software (I believe it’s 6.1?) and start anew, assuming there is a jailbreak for it… but I don’t think there is yet. 

Any suggestions on what my plan of attack should be?

 

D

I would re-jailbreak it at iOS 5.0.2 like you have now. If you do not have the blobs, you should still be able to save them and still keep it at its current iOS version.

before you waste your time updating wait a few days to see if firecore is going to release the new 6.0 jail break