Fix infuse from choosing wrong metadata for movie file using nfo

I recently added the movie Memory 2023 with Peter Sarsgaard, however infuse wants to use the metadata for the movie Memory 2022 with Liam Neeson.

My file names are:

I’m very new to nfo files so I’m working off a sample i found somewhere. Please help me correct this so infuse will use the correct data.

This is what the my current nfo file looks like.

See attachment.
Memory.2023.1080p.nfo (159 Bytes)

thank you in advance.

If you’re just looking to have the file auto-matched on TMDB it may be easier to add the ID number to the filename.

Try this


Thank you so much. What an easy fix!

Hey James,

Does this work with cloud based files?
All of my files are on pCloud and I have tried to apply this fix without any luck.

The following movies for example:

The Manchurian Candidate (1962)

The Manchurian Candidate (2004) (infuse chooses 1962)

Ghost in the Shell (1995)

Ghost in the Shell (2017) (infuse chooses 1995)

Hunger (2008)

Hunger (2009) (infuse chooses 2008)

Mother (2009) (Australian documentary)

Mother (2009) (Korean movie) (infuse chooses Austrailian doc)

I can fix them manually with edit>select another movie - but if there is a fix to permanently correct these errors - I would really like to know about it.

What ID number were you adding to the file names?

The ID numbers are from TMDB…

Ghost in the shell 2017 {tmdb-315837}
Hunger 2009 {tmdb-173672}
Manchurian 2004 {tmdb-14462}
Mother 2009 {tmdb-30018}

Using Infuse Pro 7.7 (4729)

I tested your filenames here with pCloud and it seems to be working for me.

Maybe check to ensure you have Metadata Fetching enabled in Infuse > Settings > General, and all Embedded Metadata options disabled.

For whatever reason I couldn’t get infuse to read the appended file names.
Metadata fetching is enabled and embedded metadata is disabled.

I did, however, finally find a way to make it work.

I had to delete the files from the cloud. Make infuse scan for changes. Re-add the files and scan for changes again.

This got infuse to read the new file names.

Thank you for your help.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.