firmware restore failed

Cannot jailbreak atv2 using seas0npass. Fresh restore to ios 5.3 via itunes. Have tried seas0npass versions,,, , Connects to tv fine after restore via itunes, showing non-jailbroken options, can use netflix and nhl app just fine.

Connect to pc, open seas0npass, click on create ipsw, no issues with entering dfu mode, pc finds device in dfu mode, proceeds to restoring firmware, extracting software, hear device disconect, reconnect a couple times with pc, then receive error firmware restore failed.

I have tried restoring to older ipsw, have tried with and without power cable connected, tried various usb cables. Two different computers.

I have been successful in jailbreaking this and several different atv2 devices before. I have read lots before posting. Any help would be appreciated.

[Edit] Solved! Uninstalled everything itunes/apple related, installed itunes 10.7 from and blammo. Jailbreak completed.

I wish I would have seen your post 9 hours ago… would have saved me 9 hours of pure frustration.

I had a feeling that firecore/seasonpass have not kept up with the software changes from apple, as I could NOT get seasonpass to work with 6.2.1. iTunes won’t let me go to an earlier 5.3 or 5.2… but I just found this site: and now have the older versions. Will try and figure out how to get them loaded into the ATV2… tomorrow after I get some rest.

But your answer also told me what I suspected… I’ll need to get an older version of iTunes, if iTunes is a part of this process. How did you restore using iTunes down to 5.3?

I shift + restore in iTunes. Allows .easy to choose whichever ipsw I want, provided it is downloaded. You can’t restore to the modded one, just to the stock one.