Firmware Backups Don't Show Up in Manage Backups on one ATV2, but do on a different one

I’ve got two ATV 2.  One is running 5.2 and the other is 5.0.2. I tried the other day to move to 5.2 but was like many others and waited too long and apple did their update.  Luckily my efforts didn’t mess with my current jb.

My 5.2 unit shows my backed up firmware versions underneath BACKUP MY FIRWARE on the Manage Backups page.

My 5.0.2 unit does not but I don’t think I’ve done anything different with them.  I’ve tried backing up normal and full. 

Am I doing something wrong or missing something obvious that it would show on on (4 or five backed up firmware show up) and not on the other?

The list of saved backups is taken directly from Cydia, as that is where signatures are stored. It seems there was a period where Cydia was not saving certain signatures, so unfortunately if 5.2 is not listed on the Manage Backups page then there is no way to install that version, at least for right now. Sorry.  :frowning: