Firefox

Dragged the Firefox App into my Apple TV and I can get it running using a keyboard.
BUT all the I can see is the actual navigation screen. I see no top line menus at all.
Also, I can’t get the whole window to show. It’s too big and the control buttons won;t resize the screen.
The bottom is off the screen so I can’t even move the cursor to resize it.
Any ideas?
Why doesn’t the top command menu show and does anyone have any ideas to get the window to fit the screen?

Nobody using Firefox?

Come on, tell me how yours works and how you got it that way?

The only thing I could think of is to log into the AppleTV with Fugu and go into Library > Application Support and right click on FireFox and rename it something else and have FireFox add in a new default folder. Give that a try and let me know.

I initially had a problem with Firefox and fixed it running the following command

sudo chmod -R 777 /Users/frontrow/Applications/Firefox.app

Andy

“Run the following command”
How/Where/Why?

How do you run it? Do you need keyboard access to type it in? My USB Keyboard access doesn’t look like it works with the ATV itself.
Where do you run it…find a terminal mode in the Apple TV?
Why is it needed…was your problem the exact same as mine?

I get a firefox browser window with no upper control menus at all and no way of setting up a “homepage” or managing bookmarks. The entire upper menu is missing! It also doesn’t fit the screen and I have no way of making the window smaller…the bottom of the window is off the screen and the sizing butons don’t activate.

Andy assumed you had knowledge of Terminal. You can ssh into the AppleTV using the Terminal application and run the command in his post. Have you had any experience with Terminal and Unix commands?

Gentlemen don’t discuss terminal commands and Unix experience on open forums in my part of town!
Ok, you caught me.
NONE to both questions!

There…open shame for everyone to see!

Guilty as charged. Sorry for making the assumption.

If you are using the Mac, do the following:

  1. Go to the Applications folder on your Mac
  2. Go to the Utilities folder (inside Applications folder)
  3. Open the program Terminal
  4. Type the following command:
ssh frontrow@appletv.local
  1. You should get a prompt asking you if you want to continue to accept the RSA key; enter “yes”
  2. At the password prompt type:
frontrow
  1. After logging in enter the following command:
sudo chmod -R 777 /Users/frontrow/Applications/Firefox.app
  1. When asked for the password enter:
frontrow

If you are using a WIndows machine, do the following:

  1. Go to the following site and download putty.exe http://www.chiark.greenend.org.uk/~sgtatham/putty/download.html
  2. If you have the Apple Bonjour service installed enter the following in the hostname box
appletv.local
  1. If you don’t have the Apple Bonjour service installed you will need to get the ip of the AppleTV: Go to the Settings menu on Apple TV, select General then Network you should see an IP address listed; then enter the IP address into the hostname field in putty
  2. In the PuTTY Security Alert box click the Yes button
  3. At the login prompt enter
frontrow
  1. At the password prompt enter
frontrow
  1. After logging in enter the following command:
sudo chmod -R 777 /Users/frontrow/Applications/Firefox.app
  1. When asked for the password enter:
frontrow

EDIT: I guess someone outdid me on this one. His is better than mine, thanks arfore!

I’ll try to do this as easy as possible for you. Open Terminal:
type this first: (find your own IP address in the Settings > General > About)

ssh frontrow@192.168.x.x

Password is frontrow (you will not see any typing on the screen, but it is actually typing. This is for security.

Then once inside the AppleTV type:

sudo chmod -R 777 /Users/frontrow/Applications/Firefox.app

Password again is frontrow

After that finishes then type:

exit

You can then quit out of Terminal. I hope this is what you need to complete the task. If I left anything out then just let me know.

Thanks for the help.
I think i did it the way both outlined.
For all I know, I told the computer to fry the Apple.Tv and then blow itself up!
When I get the nerve, I’ll check it out.

“Sure, I know the terminal and unix commands, doesn’t everyone these days?”

Update:

Firefox’s browser screen is still visible with no upper menu’s visible. BUT if I move the mouse on top of the browser screen…it activates the main menu bar pull down menues and I can activate the menu pulldowns with the mouse. The full menu bar is not visbale…just the pull down options. It’s like the pull down top menu is over the top margin of the screen. I suspect it’s an Apple TV screen bug.
Also…if I mover the mouse to the top left off the screen…way up the top of the Firefox browser window…I activate the OSX Apple Menu!

Again, it looks like an Apple TV screen size bug. The “About this Mac” shows an unknown processor at 1 Gig, with 256 mb memory.

Suggestions/Ideas?

:slight_smile:

I have installed Firefox and all I see is the mouse which I can move around, but I have no menus to activate or that I can see. I had this working fine before but I did a clean wipe and install to clear up some issues and the thread with how to resize the screen is gone now. ANY SUGGESTIONS!?

I’m having the same problem. I cannot see the top of the browser and the window seems shifted to the left. Any ideas?

Thanks
Will
Dallas

You may try adjusting the screen resolution the AppleTV is set to.

If that still does not help, your TV may have a high overscan that is cutting off part of the picture.

I have the same problem, no resolution changes on the TV solve the problem. Firefox top menu bar is only just visible and a strip on the left is off screen and so not visible.

You can move and resize the Firefox window just like you would on a normal computer. Unfortunately if the top menu bar is still not showing after adjusting the TV resolution, your TV is actually cutting off part of the viewable screen. The amount of screen being cut off varies between TV models.