finally mounted my MyBookWorld NAS, network drive

thought Id share in case someone else struggles with this as it took me ages to find the magic combo.


I have the original apple tv, I have a MyBookWorld NAS (network) drive (white light version) (MBW) I am running windows 7 on my pc.


first thing to do is to log into your web interface for your MBW, you can get to this from the configuration folder off the network drop down when you open my computer on your pc.


you want to go to advanced mode > network > services


check the NFS box to enable it, and add the ip address of your apple tv in the IP Allowed field (you can get this from the apple tv, google it if you cant find it - I cant remember)


go to your nitoTV and create a manual share point


enter the following


name: whatever you want

type: nfs

address: ip address of the MBW (get it from te url of the web interface or go to advanced > network > lan to get it

req auth: yes

login: MBW username - prob still admin

pass: MBW password you changed when you first logged in, if you didnt you can cchange it in the admin area of the MBW config

vol path: the default is /nfs/Public but the page where you enabled nfs with tell you at the bottom what this is if it doesnt work or you have changed it.

auto mout on or off if you want

leave the rest and save it then mount away!


Hope that helps someone out, it took me a while to figure it all out.


Thanks for this!  I spent hours trying to figure this out and thought it was lost cause - followed your set-up and works great.

I tried this setup at least 10 times and cannot get it to work. I keep getting a ‘Network Mount Failed!, mount_nfs: can’t access \nfs\Public: permission denied’ error. Anyone got any ideas? Any help would be great.


I am afraid I too am unable to connect to my MBW after following those exact instructions. Is it possible there is some naming convention issue because my Mount name is hyphenated. I get the error message “Network Mount Failed!”

OK all working now. I hadn’t followed the directions precisely and didn’t realise the Share Volume was case sensitive.

Changed the Share Volume to exactly /nfs/Public with a capital P and it worked.

Thanks so much for the effort.