Finally got new ATV Flash 4.0.1 to load with Apple 3.0.1

After many bad words, I finally got the new version of ATV flash to load on my Apple TV.
I was having the same problem as a lot of people where it would just hang up with a white apple logo stuck on the screen.
Here’s what I did…

  1. bought a new 4GB flash drive
  2. erased every old ATV file on my computer that I could find
  3. downloaded the new ATV Flash 4 file from the website (and let it download the Apple data file as well)
  4. reset my apple TV to the factory out-of-the-box configuration by pressing Menu and “-” together.
  5. updated my apple TV to the latest 3.0.1 software from apple
  6. installed the ATV flash drive on the apple TV to load the ATV 4.0.1 software

The down side is that I had to re-sync all 2,500 items from my PC after I got the damned thing up and running.

I installed the Smart Installer, but that seems to do absolutely SQUAT.

My Boxee/XMBC menu item simply disappeared and I can’t get it back. Dammit!
[update: found a post telling me how to get it back. that worked]

The F-in USB keyboard and mouse don’t work any longer. No idea how to fix that.
[update: ran the nito Smart Installer umpteen times with no success. still no keyboard/mouse.]
[update: the keyboard/mouse work on Boxee, just not on the Apple applications… it used to work on the search boxes of the Apple applications, but no more.]

At least after 4 days of having no Apple TV I finally have it back where it will at least do the APPLE stuff and play my tunes. All of this other add-on crap just seems to require a PhD… and I’m not sure I have the patience for that.

so… no good reason to update aTV Flash yet. yawn, guess i will wait for 5.0

Well this is what I thought too but am now experiencing problems with my 3.0/4.0.
First being that I can no longer click on ‘Files’ in NitoTV menu meaning I can’t access my external HD with all of my movies/shows.
I can’t install any of the packages, additions, etc such as Firefox, VLC (basically any of them).
I can no longer use the Remote app on my iPhone to control (just won’t connect anymore).

For the first time in owning an ATV with ATVflash, it was finally working the way I wanted it to and perfectly everytime.
Really wish I didn’t update to 4.0 and 3.0.
I even hate the new 3.0 interface.

What about CouchSurfer - Does it work?

Couch Surfer is not included in this version. A new version will be available towards the end of the month.

NOOOOOOOOOOOO not another new version! (still having flashbacks from the last upgrade)

Why not - or don’t you want to be able to use CouchSurfer?

Sounds like I’m having a similar problem. I’m a new ATV Flash user, and a new Apple TV user entirely, for that matter. I just did a factory wipe on the Apple TV, updated the software to 3.0.1, and then installed ATV Flash 4.0.2. I ran the nito Smart Installer in order to get keyboard support, but that doesn’t seem to have worked. Tried two different keyboards as well and connecting in via VNC on the Vine Server. No luck.

What am I missing here?

Couch Surfer is not included in this version. A new version will be available towards the end of the month.

Just asking - did I miss the update - is CouchSurfer now available?

Two fundamental issues that people keep missing are read and read!
In order for NitoTV to successfully configure your system, you have to do the following:

  1. Download and copy MacOSXUpdCombo10.4.9Intel.dmg from apple’s website (freely down-loadable) into your Documents folder on the aTV.
  2. If you were a previous 1.0 aTV owner then all the frameworks are there. If not, then you will need to find (via Google etc.) a valid recovery image which is also placed in the aTV Documents folder.

Then you run the smart updater and 90% of your issues will be gone :smiley:

True, the missing 10% include CouchSurfer - although for me it was a 100% reason why to buy ATVFlash… :shock: