Files on NAS not showing in Infuse depending on filename

I have been using Infuse for several years now, and have the Infuse Pro subscription plan.

I do not use Metadata (online or local) and do not plan to do so.
I just need Infuse to play video files from my NAS in file browser mode.

On my NAS (SMBv1 share) I have the following folder and file structure:

\HD-TRAILERS-ULTIMATE
[…]
→ !!Aktuell
[…]
----> Prehistoric Planet
------> Prehistoric Planet - Ein Planet vor unserer Zeit (Sneak Peek) [1080p] [Deutsch_English].mkv
------> Prehistoric Planet - Ein Planet vor unserer Zeit (Trailer) [1080p] [Deutsch_English].mkv
[…]
----> Star Trek_ Strange New Worlds
------> Star Trek_ Strange New Worlds (Teaser) [1080p].mp4
------> Star Trek_ Strange New Worlds (Trailer) [1080p].mp4
[…]
----> Star Wars_ Obi-Wan Kenobi
------> Deutsch
--------> Star Wars_ Obi-Wan Kenobi (Teaser) [1080p] [Deutsch].mp4
--------> Star Wars_ Obi-Wan Kenobi (Trailer) [1080p] [Deutsch].mp4
------> English
--------> Star Wars_ Obi-Wan Kenobi (Teaser) [1080p].mp4
--------> Star Wars_ Obi-Wan Kenobi (Trailer) [1080p].mp4
[…]

Infuse (macOS, iPad OS, tvOS) however only shows me the following folders and files:

\HD-TRAILERS-ULTIMATE
[…]
→ !!Aktuell
[…]
----> Prehistoric Planet - Ein Planet vor unserer Zeit (Sneak Peek) [1080p] [Deutsch_English].mkv
[…]
----> Star Trek_ Strange New Worlds (Teaser) [1080p].mp4
[…]
----> Star Wars_ Obi-Wan Kenobi
------> Star Wars_ Obi-Wan Kenobi (Teaser) [1080p] [Deutsch].mp4
------> Star Wars_ Obi-Wan Kenobi (Teaser) [1080p].mp4
[…]

So four of the files are missing and the sub-folders containing the video files are not showing up at all. :frowning:

If I rename the videos the following way, all of the folders and files are shown correctly in Infuse:

\HD-TRAILERS-ULTIMATE
[…]
→ !!Aktuell
[…]
----> Prehistoric Planet
------> 1.mkv
------> 2.mkv
[…]
----> Star Trek_ Strange New Worlds
------> 1.mp4
------> 2.mp4
[…]
----> Star Wars_ Obi-Wan Kenobi
------> Deutsch
--------> 1.mp4
--------> 2.mp4
------> English
--------> 1.mp4
--------> 2.mp4
[…]

So it’s clear to me, that Infuse has issues with the filenames, but I do not understand, how.

The issue does not occur with VLC or MrMC, but these Apps have other disadvantages and Infuse as a media player is superior in every other way.

How can this be fixed?

Thanks in advance!

Infuse will filter videos with the word ‘trailer’ in the filename and not display these in the Library.

1 Like

Thank you!

I re-checked it and it is true:
After removing “Trailer” from the filename these videos also show up.

However, in other folders there are videos with “Trailer” in the name, which are also showing correctly, e.g.: “All the Old Knives (Trailer) [1080p].mov”

Furthermore I do not understand, why Infuse decides which videos are shown and which are not. A video file is a video file and all of them should be shown.
At least we should be able to turn off this “feature” as an option.

I have literally thousands of videos with “Trailer” in the filename…