Files not updating on Infuse 5


When adding or removing files to my shares Infuse does not recognise the changes. I’ve tried bort erasing the share, erasing the app, restarting the Apple TV etc but nothing works. What can be the error?

The files are shared from my NAS through UPNP as there is something off with SMB on my NAS.

Thanks for any help I can get as this means that adding new movies to my registry does not show up on Infuse.


I am having the same problem.
My library won’t update at all. Had Infuse V4 with the same issue since the beginning of Jan, though it might be a version thing, so got V5, but still the same issue.
Never had an issue before until recently. Even my Library states that I have 0 movies, TV Episodes and other.
Im on tvOS 10.1.1, I was think that perhaps the latest update to apple TV has done something.
Any help would be appreciated.

When streaming via UPnP or DLNA, changes can sometimes be delayed. This is due to the fact that your NAS is scanning your files/folders, and presenting an indexed view of its own to Infuse.

When connecting using one of the other options (SMB, NFS, FTP/SFTP, or WebDAV) Infuse will be able to access the files directly, and display the changes as soon as they are made. Also, the Library option is only available when streaming via one of these methods.

That doesn’t really help me.
Never had an issue with infuse on my Apple TV, but since a January the library has not been updating.
I have checked my NAS and nothing has changed on that side, no firmware updates or issues.
No matter how long I leave it, for whatever reason my library is not updating.
Something somewhere has changed but I have no idea what or why.
Any extra information would be appreciated.

Yes, I’m seeing this as well. Infuse isn’t removing deleted episodes or movies from the Library even after a Library scan update. This is over NFS.

So between SMB, NFS or FTP, which one should be faster in terms of streaming and library updating? Thanks!