Files from my computer to Media Player?

I’m hoping someone can help me out with this.  I just used season pass to jailbreak my ATV2, then I installed ATV2 Flash black, and everything was going swell.  But now I want to be able to play my non-iTunes media files on my television, using the ATV2 and Media Center.  I tried to follow the instructions for Media Center that fire core provides, but the Media Center won’t detect my computer automatically when I go to “Add Share” and I have no idea how to enter the settings manually.  I know I"m probably making some sort of stupid error here, but your guidance would be so appreciated. Basically, I want ATV2 to be able to detect my computer, so that I can then direct it to play some .avi and .divx files I have stored on there.  



OK, I’ve now turned sharing on in the system preferences on my Mac, and the shared folder shows up in Saved Shares. However, every time the ATV2 tries to connect to the folder it gets an error.  I’ve tried adding users, changing passwords, using current users, nothing seems to work. 

OK, I resolved this by – get ready to laugh – restarting the ATV2.  Then, my shared folder showed up from my computer (set this up on mac in settings --> sharing). No password or username needed, this time the test connection passed without problem. Saved the settings, was able to access through media files, and there we are! Sorry for the trouble. 

Hi I have problem setting up the Media player to access my PC. When I “add share”,  it can see my laptop, but what’s the user name? The password should be the homegroup sharing password, I guess? I tried user name as “guest”, my computer names… I couldn’t get acess…

Please help!

For mine, I didn’t need a user name or pass word.  Once you set up your share and it’s showing up in your media folder, just restart the Apple TV (hold down the menu and the down button on the remote and count to seven). Once it restarts, go back to Media settings, and try to test the connection with your share folder (don’t put in a password or user name). It should be able to connect then. 

Thanks reedjulia. I reboot, then at “add share”, I can only see my pc(not the folders), when I test the connection, I got “Permission denied(13)”

really don’t know what to do…



I followed the sharing instructions but not even my PC shows up and I don’t know what to put in the fields when manually adding shares. I’m on win7 btw.
I have a Samsung TV that recognizes my PC over the network through upnp. Doesn’t Media Player do the same?

HI, I have the same problem !!! error 13 impossible to connect to my pc ??

If you’re seeing a permission denied error you may need to double-check the username/password being entered.

Also, you may want to ensure the folder/drive you are attempting to access has been shared on your PC.

Thanks for the link! That’s the first thing I read and my folders are shared and there’s no username/password. I’m confused as to why my computer is not being detected and as reedjulia mentions, any guidance regarding adding shares would be great! Some people have server names, others have IP addresses, etc. it’s all a bit of a mystery to me.