Fast forward with TV remote

Apologies if I’m doing a dumb here - but my TV remote (using CEC) no longer fast forwards the video. This definitely used to work but now it doesn’t. Previously I could press fast forward and this would start the action and each subsequent press would increase the speed of the search, until I hit the play button.

Now no matter what I do it just moves forward 10 seconds. If I keep pressing, just more 10 second skips. No fast forward anymore. I’m sure that when this didn’t work in the past I could just pause the video and press fast forward. But that isn’t working either.

How do I get my fast forward back?

Might be my TV. The remote on my one upstairs is fast forwarding just fine…

Contrary to me thinking I’d solved this, I still cannot actually fast forward on my ATV 4K 1st Gen connected to a Samsung QLED using the TV remote and CEC.

It works fine on my other two (Panasonic) TV’s, but on the Samsung the best I can get is to have to keep going forward 10 seconds with the skip.

I’ve recently replaced my HDMI cable for an 8K rated one, which fixed some other black screen issues, but still no fast forward.

Ideally I’d prefer if a double press of the skip button actually triggered fast forward mode, and each subsequent press increases the speed. But I think it only works if you keep hold of the fast forward button, which I assume my Samsung remote isn;t playing ball with…

Does anybody else have this problem? Any ideas on how to fix it?

I have similar issues except I find that depending on what remote I use depends on what kind of FF functionality I get. My CEC remote for my TV will skip forward chapters on Infuse on ATV and getting it to FF is a pain. You somehow have to hold down the right directional pad to get it to FF but the functionality is unreliable at best. Now that iOS15 is out, my iPhone remote will only scrub via the built in remote and for the life of me I can’t figure out how to get it to FF or skip chapters. Any insight into this would be much appreciated.

I managed to resolved this yesterday, and it’s an unusual bug I guess - sharing this in case anybody else is in the same boat.

I have a 2021 Samsung LED TV, this ‘smart’ TV will detect the AppleTV and display an AppleTV icon in the Source list. When this is the case the fast forward function simply does not work with CEC. IT will only do the skip 10 seconds forward or backward regardless of what you try to do.

But yesterday I was playing around and forced the TV to not auto-detect the AppleTV. I chose a ‘media centre’ as the option and renamed the Source AppleTV. Since then the fast forward/rewind function in Infuse is working as expected!

Don’t have to keep whipping my phone out now - although to be fair, I prefer the responsivness and functionality of the Remote app on the iphone.


This is a great tip! It drives me crazy that I can’t fast forward on my LG remote. I doubt it’ll work for my tv but I’d kill for that ability through CEC bc I really use that remote for everything else.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.