Family Sharing with Trakt not working on one iPad

I have installed Infuse 5 on my iPad and my two kids and logged into Trakt with the same account on all 3 and it worked great. I changed my kids to Infuse Pro. Now my wife’s iPad is not doing that. Any thoughts?

It seems to be logging into Trakt but it isn’t updating any of the Watch Indicators. Just on this one iPad. Very strange.

Once you login to your Trakt account to enable the Pro features can you logout of that Trakt account and either login with a different account or stay logged out altogether and still have that particular device keep the Pro features?

You must remain logged in.

Just started working this morning.

I have the same issue, iPhone and my 2x Apple TV’s fine as the account in-app purchased on.

My kids iPads on family sharing logged into the same Trakt account don’t show pro, any ideas?

Seriously no developer comment or reply to my support ticket. It’s been 2 days now and the 2nd iPad still doesn’t show Pro and also one Apple TV dropped pro yesterday even though logged in to trakt, I had to restore the purchase to fix as luckily it’s on my account I purchased the in app upgrade. No such ability with iPads as family sharing ones.

Is this a known bug?

Well nearly 3 days since install the 2nd iPad now shows pro is active. This does seem to be a bug

Have the same problem, works only on two of my three kids’ iPads. Provided Firecore w/ logs on Nov 28, but have not heard anything from them since.

Just got a support ticket reply stating improvements in forthcoming v5.1 might resolve this.

On a side note just installed on my 3rd and final family sharing iPad and it showed pro straight away when logging in.