fails to add share on mediaplayer

Hello

I have the Atv2 jailbroken and working. 

Up to resently it hasnt been an issue, but yesterday i had to modify my network with OpenDNS because of the kids, block some sertain web pages.

Every device works even the Apple tv. But when I try to access files on my server thorugh the apple tv mediaplayer i cant find it. When I try to add share i only find th AFP devices such as the mac in my network. But i really need to find the SMB devices because its on the microsoft platform i run the server.  It just keeps serching and searching for new device for hours nothing happes. 

And as soon i go in to my router and removes the primary and secondary DNS adress for the OpenDNS everything works like a charm again. I really need this to work. And I also need to block some websites from the kids using open DNS also.

 

You obviously have a problem in your modified setup resolving names to IP addresses; until you determine the cause of this I suggest that you work around the problem by:

  • Go into you router's DHCP settings and configure a static IP address for the MAC address used by your server; this will endure that the server always gets the same IP address.

    [To find your server’s MAC address, use the command “ipconfig /all” in a Command Prompt Window and look for the “Physical Address” on the appropriate newtork adapter entry.]

    Reboot the server and check that it has the IP address you have configure your router to issue to it.

  • When configuring the share on the ATV2 use the IP address that you have specified that your server should have, rather than the PC's name.

Remotevisitor>

it worked like a charm… the ip was already set static because I used as a seedbox also.