Failed to open input stream in demuxing stream

[Solved] In my case. After registering the SMB address as the NAS IP rather than the domain (xxx.local) when adding, the error no longer occurs for several days.

1 Like

Just wanted to say after updating to the newest beta my problem is fixed! Thanks for doing whatever you guys did

I edited my post above. It seems to be happening mainly with TV shows. I retested with the new 7.6.5 version of Infuse.

This could be part of the solution. Not sure. I was getting the same error on new files, but not the older files in the same directory. The error was also on files playing over the network while playing them locally worked perfectly. I ran this command

icacls.exe (target directory) /q /c /t /grant Everyone:F

to fix any permission problems, and that was it. New files play perfectly locally and over the network.

1 Like

Just did this twice. Added a file and it wouldn’t play. I ran the command to fix permissions and it played with no problems.

I think the issue is with permissions and Infuse is displaying an error message that while truthful, isn’t accurate.

1 Like

Suddenly I’ve been getting the same error on my iPhone on all media that I try to play, no issue on Mac and Apple TV. I updated to iOS 17.3 beta 2 yesterday (Apple pulled the update due to a boot loop bug), maybe that’s related. I don’t have any permission issues.

Edit: I solved it, it was my mistake. The app suddenly asked me if I want to allow local network access and the text said something about casting to other devices which I didn’t need so I declined it. That obviously caused the error because the app couldn’t connect to my NAS anymore.

Happens with Apple Tv 128 Gb, started mid Dec 2023. When I reboot the Apple Tv then it plays the movie or tv-show just fine. However, after we put the system to sleep and start the watching session once again the muxing error starts again. The rebooting the Apple Tv fixes it for that session.

Like others have mentioned iphone Vlc and Qnap file player works nicely.

I’ve been having this happen while attempting to play files locally. At one point, it was happening on every file I clicked on within the app.

So, I tried something else - If I select a video to play from Finder and select Infuse to play the file, Infuse loads, the error message did not display, and the video plays.

Then, I went to select videos from within the app again, the error did not display at that point either. The videos play, unless there was some other playback issue.

Pretty plz fix this soon, with cherries on top.

That article is ridiculous - it mentions putting devices to sleep and then goes on about unplugging them. That’s two totally different things.

This just happened to me out of nowhere on my Apple TV. I tested on my iPhone and files that failed on ATV worked fine. Restarting ATV fixed it.

Same issue for all movies saved on PC, cannot play them anymore on Apple TV and iPad.
Accessing the related SMB gives connection error. I tried creating another SMB by IP address instead of host name it shows the shared folders… Other apps still can see the PC by its name.

Started getting “failed to open input stream in demuxing stream” while trying to play movies saved on PC through SMB… Noting all was working fine. This is happening on Apple TV and iPad. (Latest iOS and infuse versions)

我也遇到了这个问题,但是我已经解决了。
我的Nas A通过Smb挂载了Nas B的硬盘Disc 1, Disc 2, Disc 3,在Infuse上通过Nas A的Webdav路径播放Disc 123中的电影就会出现Failed to open … 你。
通过Nas B的WebDAV播放Disc 1的电影就正常…,因此我想是不是路径有问题?

I had this problem too, but I have solved it.
My Nas A has Nas B’s hard discs Disc 1, Disc 2, Disc 3 mounted via Smb, and playing movies from Disc 123 via Nas A’s Webdav path on Infuse gives me Failed to open … .
Playing Disc 1 movies via Nas B WebDAV is fine… so I’m wondering if there’s something wrong with the paths?

I am having the exact same issue with a recently added movie on my Apple TV connected to SMB file share on my Synology DS918+ NAS.

I solved this (for now) by using an account with admin privileges when setting up the SMB share in Infuse Pro. I even tried creating a new “infuse user” with just permissions to r/w (and even read only) to the relevant folders, but I always get this error there.

Anyone got any ideas on what might be causing this? Is there something I am missing in terms of user settings in Synology that might be relevant for this?

Same thing happening to me on latest version of the app and iOS. All offline files and they open fine in anything else.